Home Assistant OS won’t boot on Raspberry Pi 4B

Up to now I have been using a Raspberry Pi 3B+ with generally without problems, at least when installing it I never had problems, but I want to do some things that I think wold benefit from the Raspberry Pi 4 but I haven’t been able to make it work and I really don’t know why it isn’t working

I connected the RPi to my PC with a cheap capture card so I can see what was going on and I saw a bunch of errors that I don’t know what they mean or how to fix them.
Some errors I saw where:
Failed to start Wait Until Kernel Time Synchronized
Failed to start Home Assistant OS Agent
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
and some others

(I recorded the hole thing and uploaded to YouTube)

I tried making a ping test to 8.8.8.8 and I got an error telling me Network is unreachable so I tried restarting the router and modem and using PiHole Unbound, Cloudflare’s, Google’s and my ISP’s DNS but nothing.
I am using a Raspberry Pi 4B with 2GB or RAM, and I am booting from a 120GB Adata USB SSD drive that I flashed the same way I always did for the Raspberry Pi 3B+, using the Raspberry Pi 4 64-bit image and following the instructions on Home Assistant installation instruction

Yes I have the same issue.
I guess no solution yet?

I end up going back to my RPi 3B+

Same problem here. After running continuously without problems for a year on a RP4-8GB on original RP power supply on a UPS, things went bad after a upgrade. Wouldn’t boot. suspecting a failed SD-drive replaced it with a brand new one. No luck. Updated firmware and tested with another OS and another RP4 gives a consistent outcome: other os (Raspbian, Ubuntu) everything OK, HAS-OS nothing boots. Transferred to USB sticks: same results (booting other os OK, HAS OS nothing. Tried “old” version of HAS-os resulted in an unstable system, with, after an upgrade, failure to boot. Finally migrated the HAS-OS to a SSD in an ARGON-M2 case, still no boot possible. I’ve run out of options, has anybody an idea what to do next?

I just upgraded my RPI4B / 4GB to boot using an SSD as I was worried about the SD card failing without warning as it had been running with it for 18 months. I downloaded the haos_933 64-bit rpi4 image and then wrote it to the SSD using “dd” on my desktop running Ubuntu. How did you write the image to your new SD/SSD ? If using “dd” you need to make sure to use -conv=fsync,notrunc and I usually do a “sync” after it’s completed just to be safe. More importantly, make sure you downloaded the correct image. There are multiple RPi images on github. You need the one that says rpi4-64 as shown below

https://github.com/home-assistant/operating-system/releases/download/9.3/haos_rpi4-64-9.3.img.xz

Secondly, make sure your EEPROM is set to boot from external USB BOOT_ORDER=0xf14 which should try to boot from external USB before trying internal SD card. Lastly, make sure there is no internal SD card that it tries to boot from.

Good luck