Home assistant pxe boot raspberry pi

Just a quick question:

  1. A synology with the home assistant image/files with tftp pxe boot.

  2. A raspberry pi 3b+ configured with pxe boot.

A.k.a a good working HA setup without SD card.

Is this possible?

in theory it would work. I pxe boot 4 x RPi 3 with LibreELEC and it works fine. I’ve never tried connecting USB hardware to it though. Not the same as HA, but still a large program/OS to pxe boot. Be prepared for a ton of network traffic back and forth.

Does your Synology not support docker?

Don’t think network traffic is a large issue. Don’t think it will completely congest the full 1gbit.

Yes Synology supports docker and I have installed Hass.io through synology docker & on Ubuntu & via the supplied hass.io vm on ESXI. But I believe rpi is the easiest because I want Bluetooth and zigbee. And none of the other ways was successful with Bluetooth. Don’t know if it’s the cheap Bluetooth stick I have. But couldn’t make it work. Only my rf 433mhz works. So that’s the reason I’m switching to hass.io on rpi.

So yeah :slight_smile:

But which of the following ways would you think is the best to run hassio from?

  1. MicroSD
  2. USB stick
  3. USB HDD
  4. Network boot

I don’t have an ssd and want to work with the stuff I already have

What I meant by the network traffic was in regards to the logging to any database file. You’re right, it’ll never saturate 1gbps but it’ll still be significant frequent traffic.

The Bluetooth USB should have been able to pass through to the docker container just like any zigbee or RF USB stick. I’ve never tried it so maybe there is an issue or special configuration though. I do have my Zwave USB stick passing through just fine but had to run the container in privileged mode. I can’t comment on ESXi or VMs.

Anyway, your question of install method is completely subjective and any answer is opinion based. The correct answer is whatever install method you are happy with, easiest for you to maintain, and works for your situation. For me, it’s docker on Synology honestly because that’s how I started and I’ve learned how to get what would be add-ons in the supervised install method working in other docker containers. I’ve never tried any other install method. As for on an RPi, yes you have to worry about wearing down the SD card, but you can offload the database to a NAS or external drive to reduce some of the read/write activity. I pxe boot my RPis with LibreELEC purely because I got tired of buying SD cards and maintaining 4 separate installs. Instead I have a central location for all of the config files and can update all 4 with the drop of a file and a reboot command. While HA is different in that respect, if you do pxe boot it, you can use built-in utilities on the NAS to do nightly backups of the config and troubleshooting and reinstallation is as simple as navigating to the folder on the NAS for logs and config.

Hi there,
I’m having the same issue with my rpi4-64. I’ve tried the following:

  1. Rpi boot and root at my Synology-> Trying to install HA-supervised does not work. It get stucked at restarting docker
  2. Installing HA-supervised (which works) and then migrating everything from boot and root to the Synology. Rpi-System is ok, but If I try to log into HA, I get the Error: (hostname):8123 refuses the connection
    Any ideas what can I do about it?
    Thank you in advance!