Home Assistant QNAP NAS Container Station 3.0.5 strange behaviour: terminal never prompts

Hi, I’m newbie with this technology so I apologize in advance for what wrong I’m going to say and please I do need your help!

I’m trying to install HA on my QNAP NAS using container station, which has been changed for weeks to 3.0.5 release.
I have tried installing both stable and latest release of first entry in docker menu.
Network mode is “Host” and I’m exposing 8123 port, and set up DNS addresses.
Finally I have mounted /config into a new folder.
Container starts, everyhing seems fine except when I click on “attach terminal” and see this:

2023-11-13 08:04:00.473 ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):
File “/usr/local/lib/python3.11/site-packages/aiohttp/web_protocol.py”, line 332, in data_received
messages, upgraded, tail = self._request_parser.feed_data(data)
File “aiohttp/_http_parser.pyx”, line 557, in aiohttp._http_parser.HttpParser.feed_data
aiohttp.http_exceptions.BadStatusLine: 400, message:
Bad status line “Invalid method encountered:\n\n b’\x16\x03\x01’\n ^”

And terminal never prompts, so I can’t type anything.

I have tried to google the error but it’s not easy for me.

Any suggestion?
Please provide it step by step

Thanks a lot