Home Assistant randomly factory resets

Running Home Assistant OS in VirtualBox
So, I was trying to apply a backup of home assistant, since for some reason my current installation was having issues. I went into the CLI, and started following the steps to apply the backup in the CLI

  1. in the CLI type login
  2. cd /mnt/data/supervisor/backup
  3. ls -l → find the required backup and note the slug
  4. go back to CLI with exit
  5. back restore <slug>
    For some reason, after step 4, the CLI randomly loaded again. I tried to run step 5, but it said that the backup didn’t exist anymore, then I tried steps 2 & 3 again to see if i got the name wrong, and it said it didn’t exist. Then, I tried opening the webpage for it, and sure enough, it said “Preparing Home Assistant”. Are there any fixes to this?

Maybe this was the issue.

Setup with default config then make change and verify it holds

Based on original issue I think they related unless more info provided. With that my first step is get back to functional, fully verify it work, restore

By issues, I mean that some of the addons weren’t working and an integration wasn’t loading properly after I reconfigured it.
The weird thing though is that it didn’t finish the setup after it was done. I don’t remember what it showed, but it wasn’t what it should have shown