Home Assistant - refused to connect at random

I think the graph is just showing an interpolation between the last datapoint at about 01:15 and 02:00, so no data is collected in that time frame.
Do you have any automations or scripts starting just past midnight, like backup or so?

We have seen many cases where a Raspi 4 with SSD disk are underpowered by an origirnal 3A PSU.
3A x 5V = 15W
15.4W is the max for the PoE ports, so unless your switch is a PoE+, then it might not be able to handle the power draw of the raspi with SSD.

I’ll have a check regarding automations, I only know at this time that 1 automation which is just to turn off a WLED and a switch at 00:30 but that was never triggered.

Luckily the switch for ports 1-16 are PoE+ so would be within range as per below spec, I can also confirm there are only 2 clients using PoE on the switch which are this Pi4 running HA then another Pi4 in the exact same hardware configuration running docker.


You switch is fine, so that is not the problem, but I do actually not know if there is a limit on the PoE hats to how much they can draw.
I have never used PoE on devices other than it was built for that sepcific device with no options for expanding the device, so the manufacteur knew the requirements beforehand.

So from checking the max wattage that the PoE hat puts out is 12.5W as per the info found on the listing page.

I could try see about limiting the SSD usage (find out its max power pull too) or try running it from separate power.

I found this article where it was apparent overheating was the cause of the issue:

I’ve went ahead and added an extra data point to monitor this.


Additionally I’ve checked when my backups occur and can confirm it hasn’t happened around this time, my backups take place at 05:00 and would be 2 weeks apart.

I’ve also checked on the temperature history and shows no correlation either.

Wait your normal cpu temp is 65°c??
Is that just me or it is pretty high?
Do you have any cooling system?

Mine Is more around 42:

For me that is quite normal, I spoke to a guy that would have his little Pi rack filled with them and reported same temperatures on average.

Would just be passive cooling so no fans.

65°C is where the automatic CPU throttling kicks in.
I have heatsinks on my Raspi chips to lower the temp and I gave up running HA on a Raspi 4, because it was hitting the limit so often, so it is only my Rhasspy wakewords function that are putting a load on them now.

Ok so, if I put better heatsinks on and run a fan across it may help then.

I was considering getting something like a NUC but I want something really low powered like a Pi considering it is running 24/7.

Checked the other Pi4 running next to this one and can confirm the temperature is the same.

This would run docker which includes the likes of Pi-Hole which is showing the hardware stats.

Again, in the same hardware config, PoE powered, same SSD size and brand.


Not sure that the heat is the cause of your problem.
The heat is just an issue with the performance, but it should not crash from that since the throttling occur to keep it safe.

To try remove as many factors as possible I have also went ahead and disabled the following add-ons:

  • DuckDNS
  • ESPHome
  • Google Drive Backup
  • Samba share
  • Studio Code Server

Following add-ons that are still enabled:

  • Mosquitto broker
  • SSH & Web Terminal

Integrations still enabled:

  • Alexa
  • CO2 Signal
  • HACS
  • Supervisor
  • Mobile App
  • Mosquotto broker
  • Unifi Network
  • Unifi Protect
  • WLED

I can’t say what is causing it, but try to install the Raspberry Pi Power Supply Checker integration.
Its probably not that but its a good sensor to have when using a Raspi.

Ok got that installed. I’ll check this in the history next time the issue occurs.

I suspect though it may stay on OK considering that all other sensor data went missing when the issue occurs.

That system is definitely running way too hot.

Official critical value is 70 degrees Celsius for a Pi 4. With passive cooling this should - depending on the continuous system load - improve/lower that by approx. 10 to 20 degrees Celsius.

My Pi 4 HA system is running fine and only touches 65 degrees during nightly full system backup during summertime, in winter it’s about 5 to 10 degrees lower.


I had heavy lockup/freeze issues back in the Pi 3B+ days. Turned out: not enough RAM, was constantly swapping to 100 %. Switching to Pi 4 with 8 GB gave more than enough room for future tasks, problems immediately disappeared.

Will be working on this as soon as possible for a cooler Pi in general, oddly the temperature even in summer stays around the same.

The network rack will eventually be placed in the attic room next year so should be much cooler as radiator doesn’t be turned on.

The critical temperature is actually somewhere over 80°C.
Raspbian OS is set to throttle at 65°C, because there is no extra cooling on a Raspberry 4 as default.
There is an option in the somewhere to change the 65°C throttle limit to 80°C.

Its not that odd actually.
It just means that you are hitting the throttle limit both summer and winter.

personally, I got an argon case:

with an addon for active cooling:

but even without the active cooling, I am around 45/48 °C