Home Assistant remote access but only via http://

Tags: #<Tag:0x00007f3263bca6c8> #<Tag:0x00007f3263bca5b0> #<Tag:0x00007f3263bca330>

Hi All

I’m a few days in to my first experiences with Home Assistant and am really enjoying using it so far!

I have spent quite some time trying to access my system remotely. I have installed duckdns and configured it and all seems fine (created my own url, etc.) I have also updated my configuration.yaml file (added http section as there was nothing in place already). Finally I have forwarded the port in my router.

I can access Home Assistant remotely but only through a non secure browser (http://). When I try using https:// I am not able to access.

If anyone could provide any help or pointers to what may have gone wrong it would be appreciated!

Thanks in advance

Steven

What error do you get in the browser when you attempt to access via https?

Sounds 100% like you haven’t enabled SSL :wink:

http:
  ssl_certificate: /etc/letsencrypt/live/hass.example.com/fullchain.pem
  ssl_key: /etc/letsencrypt/live/hass.example.com/privkey.pem

(for example - actual paths will vary)

A command line config check will tell you if there’s problems, like the files can’t be accessed.

Thanks for the responses!

The browser states: could not establish a secure connection to the server.

I hadn’t added any additional detail to the ssl_certificate or ssl_key.

I have added what you suggested and included my duckdns url (xxxx.duckdns.org) to both but still not working.

What should I be adding to this?

Appreciate the help!

Steven

You need to create the certificates first with something like letsencrypt.

2 Likes

See this community guide or this one.

That’s included in the duckdns addon, if that is what is being used.

1 Like

Again, thanks everyone!

I’ve read the community guide and have noted the part where it highlights the WAN IP. Mine is 192.168 which is a no go!

Does that flat rule me out of being able to do this until I can purchase an alternative router?

Didn’t think I would be this bad trying to set it up. Am usually fairly competent with my raspberry pi and require coding. This remote access has just stumped me fRom the get go :rofl:

I’ve rebooted and now can get back in to my system through the local address and the remote (unsecure) address is just spinning!

Fresh install coming up!!

Steven

Yes I was using duckdns

1 Like

No, you need to speak with your ISP about a plan that does not use CGNAT.

Though if this were really the case:

You would not be able to connect via duckdns even using http.

Are you sure that is your public ip address?

Not the address used internally for your local devices.

Actually you’re right, the 192.168 isn’t my public IP address it’s my local address!

I really thought I would have minimum trouble with setting this up!

Nothing is working now when I try to access HA on my browser

Will need to do a fresh install and start it all again.

If you’ve set up SSL then you always need to use https:// to access HA.