Home Assistant run failure on new Docker install (Pi 2)

I’m trying to complete an install of Home Assistant on a Pi 2 (have you tried to buy a Pi 4 recently?). I’ve installed an up-to-date version of Raspian and completed the Docker install successfully as per the installation instructions. However, when I try to create the HA container it fails “Unable to find image ‘homeassistant:latest’ locally
docker: Error response from daemon: pull access denied for homeassistant, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied.”
I have tried (successfully) to pull the home assistant from GCHR to make sure that it is available locally but the creation still fails with the same error.
Can someone point me in the right direction?

I don’t know what guide you found, but it’s got a bunch of problems. Try the official docs instead.

Two key things:

  1. It’s not homeassistant but ghcr.io/home-assistant/home-assistant
  2. You don’t use :latest but :stable

Hi and thanks. Unfortunately that is what I entered. Docker/ghcr changed it from :stable to :latest and the hyphens were in the command.
I’ve tried sudo’ing docker and created a group for docker so that I can run it from my user so it shouldn’t be access permissions.
I’m not sure where docker looks for its local repository after containers have been pulled so that I can make sure the home assistant one is there.
Definitely getting stuck!

Can you get any docker containers working? On a fresh docker install there are usually some extra steps you need to take - ie being able to manage docker as a non-root user. It sound like you did that, but to check if docker is installed properly with correct permissions, from the command prompt you should be able to test it by running docker run hello-world without needing sudo. If docker is installed properly you should get:

Hello from Docker!
This message shows that your installation appears to be working correctly.

If it fails, docker isn’t setup properly. You can checkout these “post installation steps”

If you can install other containers and get the docker run hello-world test to be successful, but still can’t get home assistant container running, can you post the run command/compose you are trying to use to install it?

That seems … exceedingly improbable. It won’t change tags and image names.

Problem solved. The installation guide says to enter the following command in a terminal session:

docker run -d
–name homeassistant

replacing the non-specific variables with your own.

However, when you do so, hitting return after each backslash you get:

docker run -d \

–name homeassistant

which does not work. The solution was to either re-paste the entire command string, then edit out the "> " sequences or to paste straight from the instructions, edit the local parameters and then submit.

Now all I have to do is work out how to use Home Assistant without add-ons.

Ok That didn’t work too well. What I meant to say was that each line typed into the terminal session had two extraneous characters (greater than and space) automatically added to the beginning on the line and this caused the command to fail. Unfortunately the submision form doesn’t allow me to post them here.

You should also consider using a compose file instead. That avoids any issues with command lines, and also gives you a container definition you can back up along with everything else.

Almost all addons have an equivalent docker image you can install and manage yourself. I’ve run it this way for awhile.

I would recommend portainer- you can manage docker through a UI and paste a docker compose in a stack instead of trying to build a large run command