Home assistant run on Android

Tags: #<Tag:0x00007f3f263848b8>

Hello i need to know whether home assistant can run on Android ? Whether it has server side as well ?

Thanks,
George

Maybe this is what you are looking for: Install Home Assistant, Mosquitto broker and Node-Red on android

1 Like

Hello, i’m Trying to install HomeAssistant to my P10 but I can’t because there are some error.
I will attach the log.
Thanks a lot for all your help.

Blockquote
/data/data/com.termux/files/usr/tmp/pip-build-env-_zy3cehh/overlay --compile:
running install
running build
running build_py
creating build
creating build/lib.linux-aarch64-3.7
creating build/lib.linux-aarch64-3.7/cffi
copying cffi/vengine_cpy.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/model.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/commontypes.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/error.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/backend_ctypes.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/cparser.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/ffiplatform.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/pkgconfig.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/vengine_gen.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/api.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/lock.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/init.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/setuptools_ext.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/cffi_opcode.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/verifier.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/recompiler.py -> build/lib.linux-aarch64-3.7/cffi
copying cffi/_cffi_include.h ->
build/lib.linux-aarch64-3.7/cffi
copying cffi/parse_c_type.h -> build/lib.linux-aarch64-3.7/cffi
copying cffi/_embedding.h -> build/lib.linux-aarch64-3.7/cffi
copying cffi/_cffi_errors.h -> build/lib.linux-aarch64-3.7/cffi
running build_ext
building ‘_cffi_backend’ extension
creating build/temp.linux-aarch64-3.7
creating build/temp.linux-aarch64-3.7/c
aarch64-linux-android-clang -Wno-unused-result -Wsign-compare -Wunreachable-code -DNDEBUG -g -fwrapv -O3 -Wall -Oz -Oz -fPIC -DUSE__THREAD -DHAVE_SYNC_SYNCHRONIZE -I/usr/include/ffi -I/usr/include/libffi -I/data/data/com.termux/files/usr/include/python3.7m -c c/_cffi_backend.c -o build/temp.linux-aarch64-3.7/c/_cffi_backend.o
c/_cffi_backend.c:15:10: fatal error: ‘ffi.h’ file not found
#include <ffi.h>
^~~~~~~
1 error generated.
error: command 'aarch64-linux-


Command “/data/data/com.termux/files/usr/bin/python -u -c “import setuptools, tokenize;file=’/data/data/com.termux/files/usr/tmp/pip-install-fcksficn/cffi/setup.py’;f=getattr(tokenize, ‘open’, open)(file);code=f.read().replace(’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /data/data/com.termux/files/usr/tmp/pip-record-nv1usfu6/install-record.txt --single-version-externally-managed --prefix /data/data/com.termux/files/usr/tmp/pip-build-env-_zy3cehh/overlay --compile” failed with error code 1 in /data/data/com.termux/files/usr/tmp/pip-install-fcksficn/cffi/


Command “/data/data/com.termux/files/usr/bin/python /data/data/com.termux/files/usr/lib/python3.7/site-packages/pip install --ignore-installed --no-user --prefix /data/data/com.termux/files/usr/tmp/pip-build-env-_zy3cehh/overlay --no-warn-script-location --no-binary :none: --only-binary
:none: -i https://pypi.org/simple – setuptools wheel “cffi>=1.1; python_implementation != ‘PyPy’”” failed with error code 1 in None

Blockquote

Did you found out any solution ?

Yes, i have changed the rom of my device

I made a full instruction video here, take a look if you dont know how to :slight_smile:
https://www.youtube.com/watch?v=0N_587XCWd0&feature=youtu.be