Home Assistant Skill in Alexa not working anymore

Few months ago I created my own Alexa Developer Skill according to guides in
Amazon Alexa - Home Assistant (home-assistant.io)

Two days ago the skill stopped working: Echo Dot told me to disable and re-enable the skill in Alexa App, I tried, but now I cannot link the account / enable the skill anymore: I receive the error message “cannot link the account” without any further hint.

This happened across night, without any significant change in the system. I also tried to restore the configuration from a backup of few days ago but was unsuccessful.

This happened also to another independent HA installation I manage.

Both installations were and are still accessible from outside with https thanks to Cloudflared tunnels if that can matters.

Not sure how I can diagnose further the issue. No hints in the logs.

hello! I am in the same situation, After two years it has stopped working for no apparent reason. and I can’t find a solution. have you been able to solve the problem?