Home Assistant Stopped recording history of temperature sensor

Hello everyone,

just yesterday I’ve used EspHome to turn NodeMCU and DHT22 into a smart thermostat.
The thing works like a charm i get the readings and all, however, since yesterday night, home assistant stopped logging changes of the sensor (presented in graph), until an update today (from 0.117.0 to 0.117.1). I don’t know if update fixed it or HA server restart but would like to know if anyone else experienced this.


It appears that temperature has not changed since 10:53PM and it definitely did, but it was logged as a straight line. I knew that values changed as i was monitoring it personally and also, while looking at console output of mcu from esphome web page, i could see the values being read.

Any insight would be greatly appreciated

I noticed that also after my update to 117 that the history did not update; but after a few hours it started tracking. I also looked at the data exported to influxDB to Grafana and it also had the same result. I didn’t think much of it since I expect some ‘hiccups’ during updates.

Probably the reason why 0.117.1 happened. Don’t know, but so many hours the history was out of update. I’m kind of sad :frowning: here’s hope that it’s better now.

I use an ESP32 to monitor a Xiaomi Bluetooth thermometer and it often loses hours. I don’t know if it’s the Bluetooth or the wifi. I check the logs in Esphome app and it shows wifi -74dBm. If I reset the ESP32 it behaves better for a day or so. Perhaps a daily restart of ESP might help. I’m gonna try it.

It did it again, but this is where it gets strange! It says it stopped at 4:10PM but i know that i looked at the temp around 11PM and it was logging it. This has to be a HA bug.

I have found my NodeMCU wth BME280 sometimes stops updating for reasons I can’t identify and it’s not regular. Whenever it does it the pressure is 670.3 so I use an automation to reboot the node me as soon as that happens.
Have you tried rebooting the device? (I am running Tasmota and they said it’s a faulty BME280 but I swapped that out and the issue persists)

I can try rebooting the nodemcu but doubt that it will do any good as a nodemcu will send updates regularly. I can see when the temperature changes from let’s say 23.9 to 24.4 and i can see the live changes as well as “N minutes ago” update on it in dashboard. But will not draw it on graph. The graph will display a constant value of 25.9.

Try it…

Well… tried it. Didn’t work. However, what did do the trick was deleting home assistant database.
So ha core stop, removed database file then ha core start…
So far, not to jinx it it worked!