Home assistant stopped responding; GUI not reachable

A little background:
First I installed home assistant on a rpi3 in a docker container. I was running osmc at the time. It corrupted my good sd card in 1 week.
Started from scratch with a new sd card, it corrupted that one too in less than 2 days.

I then upgraded to rpi4 and upgraded to boot directly from SSD, no sd attached. It worked fine for about two days but this morning I can’t reach the GUI and all automations are not working.

I am so enthusiastic to make this work but keep getting let down by ha.

The setup:
OS: Raspberry Pi OS 32 bit, latest.
Hardware: rpi4 4gb, with a NVME m2 ssd in a usb3 enclosure.
Home assistant: running in a docker container using this guide.

Things I tried:

  1. is not reachable. Tried from multiple browsers and multiple devices.
  2. The rpi4 responds just fine when I ssh into it. It’s just the home assistant service that’s dead.
  3. nmap shows that only the ssh port 22 is open. Although I can reach the home assistant observer on port 4357. It says the supervisor is connected so I don’t know what to believe.
  4. homeassistant.log doesn’t show any errors. Last line is from last evening when I was looking at sending a text/voice command to a google home puck.
  5. docker is running. I can run hello world using sudo docker run hello-world

Can someone teach me how to diagnose this and find the root cause? I haven’t restarted the rpi yet. I know that Raspberry Pi OS is not officially supported but thought I’d ask for help before I nuke everything and install Debian.

This may an issue. Not every drive enclosure will work out of the box, or at all. What can occur is install of the OS and HA will work fine, but after some period of time the machine stops responding and you have to reboot.

I had this issue with a few enclosures I tested. I ended up getting one from this list. That same page also lists how to use some quirks to fix some stability issues, perhaps you could try that.

I would suggest it may be a better idea to use this guide instead of the Raspberry Pi OS guide. Constant changes are being made to how the HA Supervisor sees and manages the underlying OS of devices and recent changes are seeing some users not able to update HA or the Supervisor as their system is showing as Unsupported and Unhealthy due to not using a supported OS.

Yes, I’m aware of the compatibility issue with USB enclosures.
It has been running fine for the past two days and the OS is still accessible right now. If it wasn’t compatible it would lock the entire system, wouldn’t it?

Agreed on installing Debian instead of Raspberry Pi OS. I guess my next step is to do just that.

Still, what else can I check to find out why it failed?

have you found a solution? I have the same issue

Yes. I backed up and performed a fresh install (yet again) using Debian. Which is the official OS for home assistant.

It has been running for months non stop now without issues.