Home Assistant stuck in UEFI shell Unraid

Hi, i have recently installed Unraid on my old Lenovo pc. Unraid is up and running, but i have a problem when i try to install Home Assistant using a VM.

Not sure if this is the correct place to post this, but hopefully someone smarter than me has allready been trough this.

I have allready checked that i use the correct info, when i make the VM.
Using Xcow2 vm file
Using 2 Cores CPU
RAM: 2048-4096
And have tried using SATA as well as VirtIO as Primary vDisk Bus.

Attached are a picture of my Unraid VM info.

This is where the OS wont boot, it’s stuck in this BIOS shell. I can type Exit and can enter a menu. I have seen someone with a simular problem and they fixed it with disabling Secure Boot. I can’t see a Secure boot option in this menu.( Checked everywhere )

Thanks in advance for any help!

Make sure that UEFi boot is enabled, but SecureBoot is disabled.
Then look at the install page on the HA documentation for what you have to do when it does not boot. It is a known situation.Text

This was not the issue. I have resolved it by not using the Arch64 based image but used the 86_64 image.

For future dummies like me:

Use the haos_ova-9.5.qcow2 Virtual Disk file from Home Assistant Github.