Home Assistant Supervised hangs due to DST transfer

This morning all my Home Assistant automations appeared to be stopped and my HA Supervised system was inaccessible, both the web interface and via SSH.
The server was still running but the hard disk activity led was constantly on and the cooling fan was running much louder than normal, so it probably was in a kind of race condition.
In my UniFi Network interface I could see that all my ESP devices were, as far as I could check, still running normally: they were still connected to my WiFi network, and network traffic was being produced.
While I was checking the connectivity this morning, the HA server suddenly came back online again, and everything went back to normal.

The interesting point is that during this night we (in the Netherlands) went through the DST transition from summer to winter time. at 03:00 DST local time the clock went back to 02:00 CET, which is 01:00 UTC.
In the HA Logbook I could see one entry from 04:03:27 local time, and all other entries were starting from 06:47 in local time.
The HA Logs in the Configuration web interface started at 06:47 so apparently the system was rebooted at that time.
All the sensors are showing entries up to 02:59, then some at 03:22 and then from 06:47 local time.
So apparently the system was online again for a short period at 03:22, but it is unclear now whether this was DST or CET.
I also have two log files being written by HA, and in both files I could see a gap of missing log entries between 2021-10-31T01:00:00 UTC and 2021-10-31T05:48:00 UTC. And 01:00 UTC is 02:00 CET.

Seeing all this data it is very likely that this problem was related to the DST transition.

While reading through this forum I can see more similar problems being reported, so I am not alone.
This clearly must be a DST related bug in HA.

Same here. My home assistant was inaccessible in the morning and extremely hot (passive cooling RPi 4). It must have started around the time of the time change.
I could still ping the host, but that was it.
I do not have any time patterns as triggers.

So why not comment on one of those topics rather than starting yet another one?

Have you tried restarting home assistant?

Because I was already finished preparing my own post when I saw the others, and it being such a rather nasty bug I thought it would be good to create some extra attention to it.

No, I didn’t have to do that because HA already rebooted itself at 06:47 CET.

Not really helpful, but mention worthy: My supervised install shows smooth transition without any problems. So just to see, that not everyone is affected…

Reading through the other related posts it might be related to using a time_pattern option in automations, which I currently still do.
Do you also have this in option used somewhere?

No, at the moment only sun states are used.

OK, thanks.
I will remove these time_pattern option from my automations, also because I have learned that this option is not preferred anyhow.
But it still is clearly a bug that should be fixed in HA.

Running Home Assistant on RPi 3b, my instance also hung and didn’t collect any data since the timezone switched to CET.

I don’t use any automations yet in HASS, at the moment i only use it to display states of various integrations, switch switches etc…

Restarting via Settings → Server Control → Restart fixed it - however, it’s a bit unfortunate to be missing data which would’ve been collected from my sensors…

Ah! Thanks, that is interesting.
So it is not related to the time_pattern option.
I hope that the pro’s will find the fix for this bug so that we will not be stung by it again next year.

I bet the calculation for the statistics has gone haywire when calculating numbers for the same time period twice.