Home Assistant Supervised (previously known as Hass.io) on Synology DSM as native package (not supported or working atm)

I have a task that runs at boot that looks like this:

now=`date +%s`
# wait for influxdb..
until curl localhost:8086/ping &>/dev/null; do 
  sleep 1; 
echo "Waited for indluxdb $((`date +%s` - $now))s"

#Restart homeassistant
docker restart -t 30 homeassistant

You should be able to add a sleep for say 300 sec. and do the same… Or try to connect to your most slow service and once that is up restart homeassistant. But, I think the hass.io guys have better solutions…

Yes, but still cant find it

If someone has experienced problems with the first launch of hass.io and in the logs sees problems with connection set in the firewall for source ip and all ports allow action.

If someone has already given, I’m sorry I did not have time to dig through the whole discussion.

1 Like

I also can not see the package in the synocommunity and I have beta’s enabled.

Ok. Solved I simply had to refresh the package centre listings twice to refresh the list with all the beta’s.

Hi Fredrike,

Did anyone mention issues with upgrading from HASS 1.05 to 1.06?
I am running the native package for a few weeks without any problems on my DS916+.
From the initial installation the upgrade to HASS 1.05 was no problem.
In HASS 1.05 the “Hass.io” menu was replaced with the “Supervisor” menu. With the upgrade to 1.06 HASS did not want to restart. I noticed that the container “homeassistant” wasn’t present in docker like before. Just the “hassio_supervisor” and “hassio_dns” containers were active and could not connect to the missing “homeassistant” container.
Because i couldn’t get in to homeassistant i had to reinstall te “hass.io” package.
Then i had to recover a backup of the “volume1/server/hassio” folder.
After that the basic functions of homeassitant did work again.
Unfortunately the “Supervisor”(Hass.io) menu was empty. Now i am facing the problem that i can’t see anny addons and worse i cannot upgrade from within Homeassistant anymore.
Do you or anyone has any sugestions how to fix this?

See “current issues” at the beginning of this topic"

Sometimes there are communication issues between Home Assistant and hass.io 16, with this error message : Unable to load the panel source: /api/hassio/app/entrypoint.js. Restarting the package seems to fix this or follow the fix below.
Fix: (I don’t think it is possible to make this automatic atm)
Stop the package (from Package Center).
Go to the Docker package page and find the hassio_supervisor Container (under the Container tab).
Stop the hassio_supervisor (if it still is running), right click and choose Action -> Clear.
Make sure that the homeassistant container is stopped.
Start the Hass.io 51 package from Package Center.
Wait a minute and make sure that the homeassistant container is started (in the Docker package) or start it manually.
1 Like

@fredrike Hi Fredrike, thank you for your awesome work first of all.

I have the HomeAssistant installed, along with the new Supervisor. I have it all working ok, and I am on version 0.106. It’s all running smooth.
I wanted to ask you how can I upgrade from here on. Do I need to do it from my Synology - uninstall/re-install? From the Supervisor (as now there is a new version - 0.106.1 presented) if I click on Update - it gives me an error and sends me to go and look into the logs. However, there is nothing clear in the logs related to the update/upgrade part.
I tried with the Synology firewall disabled and also the PiHole disabled. Still does not work.
Any ideas?
Thank you very much.

It should work with Supervisor update - just tested from 0.106.0 to 0.106.2 and it’s still working.
Double check your log files in Supervisor.

I tried again just now. Same error. Can you tell me where to look for those logs?

This is excellent. Thank you for taking the time to produce it.

When I run the ‘Check Home Assistant Configuration’ add-on, I get the following message:

WARNING: You are using pip version 19.2.2, however version 20.0.2 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

How do I update pip with this install method?

In Supervisor, on the far right you should see System tab - at the bottom there is log file content.
You can try there for start.

Thanks @fredrike working great so far. It’s going to take a bit of work to migrate from Home Assistant Core but worth it for the ease of use it adds.

Can I check if the Synology Package works with ZHA (Zigbee Home Automation - built into HA)? I haven’t been able to get my Conbee II working with ZHA via the homeassistant container. It works OK with the deCONZ addon and also with my previous Home Assistant Core container and also with Zigbee2MQTT. How to I check Docker Compose to ensure that --device=/dev/ttyACM0 is in the config for the homeassistant container? Or is there something else that I’m not aware of?

Any suggestions greatly appreciated!

Hi, it was too obvious, appreciate it. It seems that my instance cannot access github which is weird. Here are the details

I tried with both the Synology FW off, and PiHole disabled.

That’s interesting really - you have 0 successful DNS resolvs by the look, wven Fetch update data from https://version.home-assistant.io/stable.json is failing.
What does network setting for Synology look like? Are you using PiHole to resolve DNS there? If yes, can you try to point Synology to your router and use Google DNS (or any other public trusted DNS) in DNS settings?


No, there are no issues. Just like @MaVeWebpoint out (thanks) you are facing the entrypoint issue.

That is related to the add-on and not this package.

Just try. I think we had some discussions in this thread in October regarding serial usb devices.

@rosscullen ZHA works, i tested it about 1 month ago


I can’t see the package in my package center (yes I have SynoCommunity added).
Have the package been removed?

Hey, just make sure you are allowing beta packages

@BeardedConti you were right - I was filtering the NAS traffic through the Pi Hole - once I changed the DNS to Google’s - it worked:

0-03-01 14:16:14 INFO (MainThread) [hassio.store] Load add-ons from store: 65 all - 0 new - 0 remove
20-03-01 14:19:47 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.106.1
20-03-01 14:19:47 INFO (SyncWorker_6) [hassio.docker.interface] Update image homeassistant/qemux86-64-homeassistant:0.106.0 to homeassistant/qemux86-64-homeassistant:0.106.1
20-03-01 14:19:47 INFO (SyncWorker_6) [hassio.docker.interface] Pull image homeassistant/qemux86-64-homeassistant tag 0.106.1.
20-03-01 14:21:43 INFO (SyncWorker_6) [hassio.docker.interface] Stop homeassistant application
20-03-01 14:21:55 INFO (SyncWorker_6) [hassio.docker.interface] Clean homeassistant application
20-03-01 14:22:26 INFO (SyncWorker_4) [hassio.docker.homeassistant] Start homeassistant homeassistant/qemux86-64-homeassistant with version 0.106.1
20-03-01 14:23:02 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
20-03-01 14:23:02 INFO (MainThread) [hassio.homeassistant] Successful run Home Assistant 0.106.1
20-03-01 14:23:04 INFO (SyncWorker_9) [hassio.docker.interface] Cleanup images: ['homeassistant/qemux86-64-homeassistant:0.106.0']
20-03-01 14:23:49 INFO (SyncWorker_9) [hassio.docker.interface] Cleanup images: ['homeassistant/qemux86-64-homeassistant:landingpage']

Does this mean I should not filter it’s traffic through Pi Hole anymore?