Home Assistant Supervised (previously known as Hass.io) on Synology DSM as native package (not supported or working atm)

See here for a possible solution: Hassio fails to start after upgrade to 106.5

In short: there is a script running haywire when the host does not have the group audio (which is the case for most NAS systems, but not for “standard” Linux devices). Adding that group fixes the issue.

I upgraded from 105 to 106.5 and had issue to start home assistant.
Creating group audio did solve bootloop issue in my installation.

@vasjek - can you share your groups.yaml? I can’t get it working

@fredrike maybe you can add this to the package: synogroup --add audio

as reference: https://global.download.synology.com/download/Document/Software/DeveloperGuide/Firmware/DSM/All/enu/Synology_DiskStation_Administration_CLI_Guide.pdf

1 Like

I think Fizzbblizz and vasjek are talking about the groups of DSM. Please correct me if I’m wrong.

PSA: to fix the latest supervisor update do this

Step 1: create a new folder named “external” in your “hass.io/audio” folder
Step 2a: create group “audio” with no user via DSM
Step 2b: create group “audio” via ssh with synogroup --add audio

1 Like

Step 1 worked for me. HA is working fine.
But the docker container Hassio-Audio:8 is bootlooping every 20sec.
Adding the audio group to dsm didn‘t help so far.
Does anybody know what this is for?

Yes, DSM (or better Unix groups in the underlying Linux system).

Use ssh to get to a shell in your DSM, then do a cat /etc/group and make sure the audio group is listed there. If it is not, you did not create the group. On my DSM, the Unix group was created by using the control panel and adding a group.

Hi Fredrik!

I did the following actions, and ended up with some problems:

I got my synology ds 218+ the other day, and quickly set it up with docker, and home assistant, as i realized this is not what i wanted, and Hassio is, i uninstalled it, and set up Hass.io through your package!

altough, DSM package manager says hass.io Beta is running, i cant access the site throgh IP:8123, i am getting: ERR_CONNECTION_REFUSED
Also in DSM notification panel, im getting this message a few minutes after rebooting the NAS saying Hassio_DNS har stopped working.

Checking the docker containers after the hassio install, i see “Homeassistant” is not running, and cant be started, Hassio audio is stuck in a reboot-loop. And Hassio DNS also loops.

Any ideas?

Currently uninstalling everything on the NAS except my UniFI cloud key to start over!

Hm i suspect my initial hass.io install was corrupted, due to the repository being very unstable.

Trying to re-install the package again now, im getting a message in the package manager saying the package is missing from the repo.

Trying to access the URL manually, im getting a 502 bad gateway static cloudflare error rmessage.

Managed to re-install the package, but getting the same errors.

What am i missing?

Now its working! hassio-audio runs stable.
After adding the group audio to DSM, creating the folders /audio/external AND /audio/internal/states the hassio-audio container runs.
Fount it in the containers’ log that mounting of this folder failed.

Thanks for all your help!


How to setup a static ip as I am running into some issues with the adguard addon?

Thank you! This boot looping was driving me insane, I was thinking that all the work I’d done configuring HASS was going to be for nothing, but this has saved me!

What’s your log file looking like? I installed Portainer the other day to manage my docker containers. I use it to view the Hassio logs. Bearded Tinkerer has a tutorial

Yesterday I was getting an issue in the logs that my audio/external folder didn’t exist, so I had to manually add the folder and then it started back up. Wonder if that’s what you’re getting.

1 Like

Hi, thanks for the suggestion. I did follow this procedure twice but unfortunatly it doesn’t change anything. I still have an empty supervisor screen with the “Unable to load the panel source: /api/hassio/app/entrypoint.js” message. Does anyone has any sugestions?

Can anyone tell me if it is normal that the containers “hassio-supervisor” and “hassio-dns” restart every 3-4 minutes while container “homeassitant” stay’s active all the time? (This is not related to the problem above. I allready noticed this the first time i installed the native synology package)

I’ve also got the: “Unable to load the panel source: /api/hassio/app/entrypoint.js.” error when trying to access the Supervisor pane. This is on a brand new installation of DSM/Docker/Hass.io package/ Home Assistant 0.106.5 on my DS418play.

My Log shows this error: “Client error on api app/entrypoint.js request Cannot connect to host ssl:None [Connect call failed (‘’, 80)]”

Tried the fix in the OP, and various other “fixes” I’ve seen around, but nothing works. Any ideas? Thanks in advance.

All containers run fine except for hassio_supervisor, which is looping…

edit the error shown in the hassio_supervisor container is:

CRITICAL (MainThread) [hassio.bootstrap] Can’t find Docker socket!

Do you have your firewall enabled on your NAS?

No, firewall off!