Home Assistant Supervised (previously known as Hass.io) on Synology DSM as native package (not supported or working atm)


Just installed the package and seems something is wrong.
I was able after install to access Home assistant on the port 8123 and do the setup (works fine, it also detect my devices)
After the setup from the dashboard I try to access the supervisor and … and got the classic error already mentionned here.

I try to apply the process written on this document: https://docs.google.com/document/d/1GvOX4zTPJinXNJ4WqtHcQUSiQ0HVdRMg2tHVkmJh60k/edit#

It’s not working and even worst now, I also cannot access anymore home assistant.

Here is what I try to fix the issue, and not working:

  • follow process on https://docs.google.com/document/d/1GvOX4zTPJinXNJ4WqtHcQUSiQ0HVdRMg2tHVkmJh60k/edit#
  • stop all containers, restart them one by one
  • stop all containers, clear them and restant them
  • start stop the package, remove containers, restart the package
  • uninstall the package, clear everything and restart DSM, reinstall the package -> same error, same problem if I try to stop/restart package nothing accessible anymore

More input to debug:

  • seems the container of supervisor enter in a loop of error (stop/restarting loop)
    Keep showing:
    20-05-11 18:08:11 CRITICAL (MainThread) [supervisor.bootstrap] Can't find Docker socket! + after a long error stack from python.

I have also several errors related to connections on the container of homeassistant:
2020-05-11 20:07:07 ERROR (MainThread) [homeassistant.components.hassio.handler] Client error on /ingress/panels request Cannot connect to host ssl:None [Connect call failed ('', 80)]

If anyone have an idea how to fix all these issues?

For the moment, I’m going to uninstall this package and all the docker containers, etc … because if I keep them its and endless loop of restart …

Could someone tell me if you can update hassio? I installed the packages a while ago and I’m in version 0.107 but I don’t know if I have to stay in this.


Yes - you just go to the Supervisor tab and update from there. It’s a really great package.


It’s so sad to hear all this. I was testing the package and planned to move my production HA instance to it in the next days and what a surprise :frowning:
I think the package is great and I already said it a couple of times so far. It makes my dream to have hass.io running on Synology come true. Without it we only have HA Core which lacks so many cool things e.g. as painless addons management, upgrades, full docker container restart control etc. It all is possible with this DSM package. I’m really hoping you won’t quit it.
That is true, that some people just don’t appreciate others work. I know that, but I think the majority does. It’s the “bad” voices, who shout louder and more often I think. Only that.
Keep up the great work and don’t bother the ones who don’t appreciate it.


I’m not planning to stop working on this :slight_smile: , but it would certainly help if it were more of a community effort with the support issues.
I mean, we had some issues when the Audio container was introduced, I built a temporary solution (but couldn’t really test it as I never had the issue). And then never heard back if the “new” package was needed or what happened.
There seems to be some issues with the Multicast container (I can’t get it to start on my installation). Where this might be a solution, but I really don’t know as it might break Synology’s internal packages (that requires all Docker networks to be created via the Docker UI):

And then we have the usual,

Where no one answers (but on the other hand, have @MLKiiwy really read the first two posts).

So, for hass-supervisor to work flawlessly on Synology we need to work as a community and be structured about what is issues that needs fixing (on the Synology side) and what is just “PEBCAK”. I might set up a github page with wiki and issue tracker so we could keep things there (but again, as a team effort).


That’s good to hear!
As someone who installed your package just before it hit the Synology repository (early this year) I had very little problems with it. Therefore as a satisfied user didn’t post here.
I think now is the time to say that there are a lot of very satisfied users running your package without problems or who are able to solve the glitches by themselves (restart the dockers). So from me and I guess all those other users not regulary visiting here; thanks very much for your great work, highly appreciated.

I’m just a dumb user and have not much knowledge of the backgrounds of the system therefore giving help to these users is not possible for me. Will see if I can do something with the documentation of common problems/answers.


Like so many I just want to say thank you @fredrike and I apologies for not saying that before this point! I would be curious to see some stats on the environments HA is installed on, I suspect Synology makes up a reasonable number and in no small way that’s down to you! Certainly, I’m seeing increased posts in the forum where Synology is mentioned.

I’ve been using this package for give or take a year now, overall, with no serious issues. On the occasions I have ran into issues through reading this thread of directly asking a question I’ve found the answers.

While there are very few technical issues asked in this thread I could answer, you do make a good point and I need to try and jump in more. Again, thank you :slight_smile:


Just installed this package on my NAS, thanks for making such a project happen, @fredrike! :slight_smile:

Ok, I’m going to try.

Thank you very much for the great work @fredrike!

I’m not just “a dumb user” as @GH2user :slight_smile: (no offence, buddy :)). I try to help people with other modules which I’m aware of. I even managed to amend Tado integration for NodeRed myself.
However, I do not have deep knowledge of Synology-Docker-Linux connections. So I can’t help either.

I would advise to take it easy and just advise people to use other options to set up hass.io. It may be quite a lot of different cases on Synology because they have a lot of packets which may influence somehow hass.io. So if some users try to install standard packet which works perfectly for many other people and getting serious troubles, it means that hass.io on Synology is not their way.
There are several other options to install hass.io. And I’m pretty sure that in about 1 year we will have more simple and maybe more common variants to use Home Assistant with other packets.

The last time, some containers spontaneous stop. Put them on in Synology but after a few minutes again stopping, after a while i got 11 containers running again but not the Log container see picture. What went wrong?
Also Hassio is not restarting from the browser with server restart, how to restard Hassio?

Not sure I follow you, but I suggest you read the log of the “logviewer” container there are usually some hints on what’s going on.

I don’t think you can restard. Hassio should never be restarted, but you can restart HomeAssistant Core by the service-call homeassistant.restart. The package Stop/Start usually works too.

Hi Bonestaak,
I experience almost the same with addon_core_check_config

so i cannot add addons that are not listed in the store :frowning:

However I believe it is doing what it suppost to do?

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] udev.sh: executing…
starting version 3.2.9
[08:32:15] INFO: Update udev information
[cont-init.d] udev.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[08:32:15] INFO: Setup udev devices
[08:32:17] INFO: Don’t worry, this temporary installation is not overwriting your current one.
[08:32:17] INFO: Installing Home Assistant: latest…
[08:32:17] INFO: Please be patient, this might take a few minutes…
[08:32:49] INFO: Installed Home Assistant 0.109.6
[08:32:49] INFO: Making a copy of your configuration for checking…
[08:32:49] INFO: Checking your configuration against this version…
[08:34:00] INFO: Configuration check finished - no error found! :slight_smile:
[cont-finish.d] executing container finish scripts…
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

Yes, you are correct. Function of this add-on is to retrieve latest version, temporarily install it and check against your configuration. After it finishes it gives you status

And it then stops - because work is done.

Thx for the info, just started with this.

1 Like

I believe mosquitto doesn’t work as it should be expected.
it is stiched to hassio network inside docker.
it should be stiched to the host otherwise it cannot discover other devices than the hassio itself.

[13:14:15] INFO: Setup mosquitto configuration
[13:14:15] INFO: No local user available
[13:14:15] INFO: Initialize Hass.io Add-on services
[13:14:15] INFO: Initialize Home Assistant discovery
[13:14:15] INFO: Start Mosquitto daemon
1589454855: mosquitto version 1.6.3 starting
1589454855: Config loaded from /etc/mosquitto.conf.
1589454855: Loading plugin: /usr/share/mosquitto/auth-plug.so
1589454855: |-- *** auth-plug: startup
1589454855: ├── Username/password checking enabled.
1589454855: ├── TLS-PSK checking enabled.
1589454855: └── Extended authentication not enabled.
1589454855: Opening ipv4 listen socket on port 1883.
1589454855: Opening ipv6 listen socket on port 1883.
1589454855: Opening websockets listen socket on port 1884.
1589454855: Opening ipv4 listen socket on port 8883.
1589454855: Opening ipv6 listen socket on port 8883.
1589454855: Opening websockets listen socket on port 8884.
1589454855: Warning: Mosquitto should not be run as root/administrator.
1589454855: New connection from on port 1883.
[INFO] found homeassistant on local database
1589454856: New client connected from as auto-96DBB26A-C9AC-2B5E-D4DC-08C17F7C6327 (p2, c1, k60, u’homeassistant’).

Guys, I had sometimes issues with containers as well. The restart of the whole Synology worked for me. Sometimes I had to restart it two or three times. I do not know why. Guess, it may be something wrong with Docker on Synology. However, recently I realised one problem on my side. I did some automation on Node Red. It was with loops, I think. And once per day or even more often loops overflowed the available memory and one of the containers may freeze or stop. This behaviour stopped when I removed these loops in Node Red.
So please check what may you did in your automation. Maybe you add something new, maybe you changed something. The container system works perfectly if nothing wrong inside.

What are you using besides HA that talks to MQTT? Did you try any external devices? And did you try using Synology host IP address?

DId you look at the log inside logviewer log? I’ve tried installing it today and it’s still working OK. Although I find Visual Studio Code for editing configuration and viewing HA log file much easier to use and more easy to the eyes :slight_smile:

What do you mean by hassio? Any of the hassio_* containers? Those are not intended to be stopped by hand. Supervisor should be the one controlling them when needed.
You can stop that by going in Synology package center and stopping package there. It will stop supervisor gracefully (hopefully). And when you start it from there it should start everything needed for HA to work.

Aha, now i always restart my DS218+ when i changed something in configuration.yaml.
This is much faster.