Home Assistant Supervised Rpi

Tags: #<Tag:0x00007f326eda16d0> #<Tag:0x00007f326eda14f0>

I’ve tried repeatedly to install HA supervised according to the instructions posted here but I cannot access the web gui (I can, however, access the “observer” page on its designated port.) I’ve been Googling for a couple days now, and see many have come across this problem, but no fix I’ve found works. I’ve tried installing docker-compose too, but that’s not going for me either (starting from scratch again tomorrow.) Without docker-compose, I’m at a loss where to find the “network_mode” setting that is apparently causing the issue. I want to run the supervised version so that I can also install pi hole on this machine. Maybe you can suggest an easier way to do that than using Docker and thus side-step this whole issue?

Thanks for any advice. :slight_smile:

Does it need to be Pi-Hole? If not you can install Home Adsistant OS and then install the AdGuard Add-on.

1 Like

That does look like a good substitute, but then how do I access other integrations? Is it just a matter of installing their Gits?

Thanks for the tip! :slight_smile:

You’re confusing integrations and add-ons here. Integrations are used to connect devices/services to Home Assistant like the Philips Hue integration to integrate a Philips Hue hub.

Add-ons are used to get additonal software like Ad-Guard, AppDaemon, Node Red etc. If you use Supervised, these can be installed through the Supervisor Menu, if you use Home Assistant Container (Docker install) you need to install and configure them yourself. The add-ons are just docker containers that are slightly modified to integrate well with the Home Assistant Ecosystem.

I’ve just run through my own guide on a Pi4 with SSD boot - I had no errors.

Everything up and running from start to finish with a fresh install of RaspberryPi OS Lite (linked in the guide) and HA Supervised (copy pasted everything from the guide) in under 15 mins. I can only assume you haven’t followed the guide properly as it works as intended.

As @Burningstone suggested, the AdGuard Home add-on is very good. I run that myself on multiple installs and have found it to work reliably and it functions in the same way as PiHole did when I used to run it.

The installation of pihole pauses for a few minutes in the middle…and if you don’t know better, you may think it’s installed. Make sure you wait for the pihole installaton to complete.

He doesn’t have an issue installing Pihole, he has an issue getting HA up and running.

Isn’t this addon deprecated in favour of Adguard now anyway?

Yeah. I get the impression he wants to run Supervised and then install Pihole at OS level, or using Docker.

Thanks for all the advice! Indeed, kango_who that is what I was trying to do. My pi is a 3, maybe that played into it. :woman_shrugging: I have returned to the hass.io image and am working with AdGuard… currently I’m stuck in a 502 bad gateway (working on solving that with a security key; that problem may bring me back. :wink: )

Ha… brain fog. It’s the SSH add on that’s giving me the 502, NOT AdGuard. :wink: