Home assistant third-party addon not installing (error 400)

I’m pretty new in advanced of HA, but use it in my home for couple years.

Now just try to install CUPS add-on homeassistant-addons/cups at main · MaxWinterstein/homeassistant-addons · GitHub

My steps:

  1. Add addon repository “GitHub - MaxWinterstein/homeassistant-addons” by Three Dots Menu.
  2. Click to install button.
  3. Get “Unknown error, see supervisor logs
  4. Get in logs:
2024-03-11 14:42:22.177 ERROR (MainThread) [homeassistant.components.hassio.handler] /addons/1e14b3fb_cups/install return code 400
2024-03-11 14:42:22.178 ERROR (MainThread) [homeassistant.components.hassio] Failed to to call /addons/1e14b3fb_cups/install - 

So it is Error 400.

  1. Check for another add-ons from this and other repos — its installed an working as expect.

Please explain: it is out-of-date code in add-on (due to experimental status, last edit 4 months ago) or my system isn’t correct? Or I am installing is wrong?

Btw, i’ve read the tutorial for add-on developers, familiar with config&build files, compare it with examle but no result…

HA OS 12.0
HA Core: 2024.3.0
Hardware: Raspberry Pi 3, armv7

Just tried to install it , same error

RROR (MainThread) [supervisor.docker.interface] Can't install ghcr.io/maxwinterstein/homeassistant-addon-cups-armhf:3.0.3: 500 Server Error for http+docker://localhost/v1.43/images/create?tag=3.0.3&fromImage=ghcr.io%2Fmaxwinterstein%2Fhomeassistant-addon-cups-armhf&platform=linux%2Farm%2Fv6: Internal Server Error (**"Head "https://ghcr.io/v2/maxwinterstein/homeassistant-addon-cups-armhf/manifests/3.0.3": denied")**

“Head “https://ghcr.io/v2/maxwinterstein/homeassistant-addon-cups-armhf/manifests/3.0.3”: denied”)

1 Like

About what kind of authorization it messages? On git? But where i can this do?

My guess was that the repository must be ‘public’ for this? This is true?
Why then can you install other addons from there? Or does the author not have the assembled image (in the ‘packages’ section)?

Today is my first day with containers. Please tell me what I understand correctly and what not.
Now my options are as follows (for the HassOS installation option), isn’t it?

  • clone git and install locally;
  • fork the git project, install the add-on from my own repository;
  • use portainer and run it as a separate software.

Better: ask the author to set it public. Probably something he forgot, as he seems to have added armv7 support later.

I had the same problem with another Add-on. Turned out I had the corresponding add-on repository already installed for another add-on from the same developer. Maybe check if that is your problem, too. I think there should be an “add-on repository already already installed” error instead of the misleading error 400 message.

I’ve create issue on github and developer says that there no package match tag ‘latest’ for target architecture. Because he don’t want build it, as Raspberry 3 is unsupported and slow. :worried: :worried: :worried: