Home Assistant too unstable

I’ve been running Home Assistant (hassbian) on raspberry PI for a year and the system crashes constantly after four to six weeks. I can still login via SSH but its impossible to get Home Assistant up and running
Here’s the output from the status command. If development cant tell whats wrong the I will abandon HA!

That’s not really what this subforum is for…and it comes off as a tad bit rude.

What do your logs say about the failure? not the systemctl but the actual home assistant logs


I was getting errors similar to this when my sd card was failing. Switched over to a USB thumb drive for now until I can switch to a USB external HDD for my pi.

1 Like

Good news, we’re all users here. We can help you here, or you can pop over to the Discord channel, and we can try to help you work out what’s wrong with your system.

It could be as @firstof9 said a problem with your SD card. It could be something else, but sudo dmesg|tail -n 50 will help us know.

Alternatively, continue to be rude and demanding, and see how many people volunteer their free time to help you :wink:


i dont think this post is intentionally trying to be rude, i think its a case of missing punctuation,
if one reads it as " i will abandon H.A. " i.e. Home Assistant, then its a different interpretation

Okay your having problems, what have you done to correct them?

Have you tried:

  • different power supply or powering from a UPS
  • different SD card or storage device
  • different location for the RPi
  • connecting by ethernet
  • a different version
  • searching the forum for similar issues
  • limiting the recorder (recorder: purge_interval: 1, purge_keep_days: 3)
  • checking space available on SD card

You didn’t mention much about your setup:

  • are you using custom components
  • using things they may still be in beta testing
  • did the problems start after changes in setup

I don’t know of any application that is available for free, that does a much as Home Assistant, for as many different components and is supported by as many people as Home Assistant. Not to mention as many Nationalities and Languages.

Most of the problems that I have had, I have caused not the developers.


I run into similar posts on kodi forums, where I am a team member and mod. The correct response is:

Most open source developers don’t give a monkey’s about how many people use their software. They do it out of personal interest in a topic, and a desire to help others. If you stop using it so be it, no loss. If you want to stick around and help by assisting us to fix your difficulties then we’ll do our best to help.


I was having the same issue with a raspberry pi too, about a year ago i switched my HA instance over to a small pc like this one "Dell OptiPlex FX160 Intel Atom 230 1.6GHz 4GB RAM 50GB SSD Mini PC "; which i purchased on ebay for 50 bucks and so far i can’t complain. I mean my HA runs without any issue unless I caused it.

Thanks for all replies on the subject! My solution was to switch to the Proxmox virtual environment running on a HP DeskPro 400 mini PC. The configuration runs great and if I do tests, and the system crashes, I can always reinstall the backup image in a couple of minutes. I strongly recommend the developers to support the virtual server environments as good as the Raspberry Pi

They do. It’s called Docker.

Should have specified Hassbian.

But Hassbian is only Raspbian with Home Assistant pre-configured with a python virtual environment.

Just use Docker. It requires nothing special but Docker to be installed on the OS.