Home Assistant Using Previous Entity ID for Automations After Device Rename

I recently repurposed one of my spare Z-Wave Switches to control a Propagator. Previously, I used it to control a Christmas Tree, and so using the Z-Wave options built in to Hass, I renamed the Z-Wave Switch from ‘Christmas Tree’ to ‘Propagator’. This worked, and on the main Hass dashboard, the Switch has the correct name/entity ID etc (switch.propagator_switch) and is controllable by clicking the switch;


However, in my automation the Switch wasn’t being turned off/on as expected. So, I went over to the Service Dev Tool and found that although the correct ‘friendly’ name was listed, the Entity ID as listed in that menu was using the previous entity ID for this switch (switch.christmas_tree_switch);


If I use the previous entity ID, the automation works.

How can I get Home Assistant’s automation framework to use the new Entity ID? I have restarted my system a few times but to no avail.

Many thanks!

Yeah, it’s a bug introduced with 0.63 and the new entity registry. You need to update entity_registry.yaml too.


That worked, thank you!