Home assistant variable cache

Hi all,
I’m using arduino connected to usb to my raspberry (ha core version is installed in raspberry).
Inside configuration.yaml I have this:

  - serial_port: /dev/ttyUSB0
    serial_baud_rate: 57600
      - name: fumo
        pin: A1
        pin_mode: ANALOG
        differential: 20
      - name: batteria
        pin: A0
        pin_mode: ANALOG
        differential: 20    
      - name: rete
        pin_mode: PULLUP
        pin: 13

now I have to change the pin of arduino… but Home Assitant doesn’t like it…
For example I changed the sensor.fumo from A0 to A1 and sensor.batteria from A1 to A0 but now HA shows:
It changed the names…

I tried to erase the browser chace, remove the config lines from config.yaml, reboot and insert again but the problems remains…

I don’t now how “refresh” the new pin…


I may be wrong, but you may need to remove the actual device and allow Home Assistant to rediscover it.

The problem solved when rasberry changed the usb number …