Home assistant webhook error

Hi everyone. Receantly I’ve configured google home mini with my HA. I am using cloud so I enabled webhooks from config page. I added automation like this:

- alias: 'Obluga IFTT dla google assistanta'
  initial_state: 'on'
  trigger:
    - platform: event
      event_type: ifttt_webhook_received
      event_data:
        action: 'call_service'
  action:
    - service_template: '{{ trigger.event.data.service }}'
      data_template:
        entity_id: '{{ trigger.event.data.entity_id }}'

And by using IFTT I created google assistant action. It respond to me when I fire it but no action is done :frowning: And in HA logs I see:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/webhook/__init__.py", line 97, in async_handle_webhook
    response = await webhook["handler"](hass, webhook_id, request)
  File "/usr/src/homeassistant/homeassistant/components/google_assistant/helpers.py", line 239, in _handle_local_webhook
    result = await smart_home.async_handle_message(
  File "/usr/src/homeassistant/homeassistant/components/google_assistant/smart_home.py", line 27, in async_handle_message
    config, user_id, source, message["requestId"], message.get("devices")
KeyError: 'requestId'

My That action looks like this (I removed vulnerable data):

What might be the problem?

I think you’re trying to use the google_assistant component, but you’re actually using IFTTT. Just remove the google_assistant component.

Remove it from where? I try to use google assistant cloud’s webhook in IFTTT automation

Whew. This is… very complicated.

  • Home Assistant Cloud doesn’t need anything else to set up.
  • You only need Home Assistant Cloud webhooks with IFTTT if you want to add custom phrases.
  • First of all, remove the already existing webhook automation and IFTTT applet.
  • Go to the Google Home app and hit the plus in the upper-left corner.
  • Choose set up a device.
  • Choose already have something set up.
  • Tap the search icon.
  • Enter Home Assistant.
  • Choose Home Assistant Cloud by Nabu Casa.
  • Done!

If you want to see the advanced config options, go to this page and scroll down to Manual Configuration.