Home Assistant will not connect to network after latest update

Tags: #<Tag:0x00007fc3ee8fe9e0> #<Tag:0x00007fc3ee8fe878>

About a week ago I briefly logged into Home Assistant and saw there was a couple of pending updates, so I clicked update on Home Assistant core, clicked yes when It asked me whether I wanted to create a snapshot of it then, once I saw it was creating the snapshot I closed the tab. I meant to come back later and update Home Assistant OS, but forgot and only tried to log in again a few days later. When I tried to access it using exactly the same method I did last time It didn’t work. I also tried accessing it through my DuckDNS domain but that too didn’t work. I decided to check on my Pi the lights in the ethernet port where off. The other led’s on the board where on, but for some reason ethernet wasn’t working. I tried unplugging the ethernet cable then plugging it back in, but that didn’t help, neither did turning the Pi on and off. Has anyone else had this issue, or does anyone know how to solve it? Also, just a few days before any of this happened I created a full snapshot, but didn’t download it or save it anywhere other than the micro SD card. Would someone be able to send a link to a guide on how to get the snapshot off the SD card, ideally on Mac but I can use a windows VM, as that’s another option if there’s no other way to fix this.

So apparently after the latest update my mesh wifi doesn’t like HA, as when I plugged the ethernet cable directly into the modem it works fine. Very strange