Home Assistant with iOS

Dear Forum.
I have installed Home Assistant on my QNAP, which works fine when accessing through the browser (from “inside” and from “outside”).

However, the iOS app does not work at all. I get an error “invalid client id or redirect uri”. I have tried everything…and nothing works!

I have searched on several forums - and nobody provides an answer.

What should I do? It seems like a simple problem, which should be solved with a simple solution…:slight_smile:

Kind regards,

Are you using DuckDns or the cloud to expose your Home Assistant outside your network?

No - i use my public qnap adress.

I don’t know the app, I just downloaded it to check out, but it refuses to connect for some reason.
Up till now I use the Safari Shortcut, which you get by opening HA in your Safari browser, then saving the page on your Home Screen. I never had issues and HA sees the login token from when I logged in internaly when I am not at home. So it’s simple and straight forward.
Maybe you want to try that out as alternative?

I have tried that - and it works. However, I would prefer the app…anyone who have had the same problems?

So, you can access HA with the browser but not the app? My app version 1.5.0 works fine. Here are some of my settings:

URL: https://xxx.duckdns.org:8123
Use legacy authentication OFF
Show advanced settings OFF

Under Advanced Settings both options are also OFF.

The connection through duckdns gives the same error…

With the browser, https is working and http is not?

Http. I cant fint advanced settings…should I edit the actual configuration file located on the server to get access to these settings? Sorry, I’m a complete novice in this area…!

OK we need to fix that first. What instructions did you follow to install Home Assistant? I can think of a couple of possibilities.

I installed the QPKG on my QNAP - and it worked immediately through the web browser. Afterwards I tried the app, and it dig not work.

When starting the web version, It asked me for a user name and a password - and that was it.

The configuration file is pretty simpel - please note that I have inserted the duckdns instead of my qnapcloud-address. None of them are working through the app, but both are working through the web browser.


Name of the location where Home Assistant is running

name: Home

Location required to calculate the time the sun rises and sets

latitude: 55.8703
longitude: 12.3574

Impacts weather/sunrise data (altitude above sea level in meters)

elevation: 0

metric for Metric, imperial for Imperial

unit_system: metric

Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones

time_zone: Europe/Copenhagen

Customization file

customize: !include customize.yaml

Configure a default setup of Home Assistant (frontend, api, etc)


Show the introduction message on startup.


Uncomment this if you are using SSL/TLS, running in Docker container, etc.


base_url: http://dkhns.duckdns.org:8123

Discover some devices automatically




Weather prediction

  • platform: yr

Text to speech


  • platform: google

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

If you put https:// instead of http:// it does not work. That is likely a large part of the issue.

I am not too familiar with that installation Do you have a Hass.io menu on the left side? If not what instructions did you use to install DuckDns in Home Assistant?

It does not work with https - however, I have not tried anything else in that direction.

I have attached a picture of the web-version of the Home Assistant (the left part with the menu).


Regarding the duckpins-installation…I might have done it the wrong way. I just registered with duckdns, so the address points at my IP-address (which is dynamic). I thought this worked the same way as the QNAP-system, where you also register with them, so they keep track of the right IP-address.

I think you need to look again at https as it’s essential for security when connecting from outside. Did you set up the port forwarding and is the certificate in the correct file.

I don’t know much about how the iOS app works but it could be that as duckdns isn’t working as it should the app won’t connect

Thanks for the answer. I’ll try to look at a https-access instead. However, the port forwarding is ok, because I have access from outside through the web browser.

Here is the guide that worked for me, assuming you are running in a virtualenv.


If you are running a docker installation, I have not worked with that.

Thanks for the answer. I decided to install a container station with Ubuntu…and that worked :slight_smile:

The HA is really amazing…i experienced that it is possible to control my Unifi installation through the HA - although I have a controller on my QNAP, this is really smart :slight_smile:

Now I have to dig into all the other things available in the HA.

1 Like

How do you do that? I am looking into a wireless mesh solution for my home.