Home assistant won’t boot up

Hello everyone
I come here after trying almost everything possible. Let me explain:
I recently got an old pi3 from my dad and I was planning to install home assistant on it, I tried on a couple of SDs but to no avail, the light on the pi3 turns once green and then only red light. I have installed on it homebridge and raspian OS and the pi3 works.

I just bought a new SD recommended for home assistant and installed it in two different ways (ether and raspberry imager) but with the same result… I don’t know what to do anymore… I will try to flash with a Mac instead of Pc but I don’t have much hope, help anybody?

Hey there,

what microSD were you using?

Have you tried hooking the RPI up to a monitor in order to see probable error messages?

Also ensure that your using the RPI 3 image and not the RPI 4 one - since this is the one selected by default on the webpage.



I did connect it to a monitor but nothing happens on the monitor. The pi3 blinks green a couple of times and then nothing, like if there is no boot file on the SD. I have tried the new latest OS but nothing.

Yes I am using the pi 3 version, I tried with Etcher and Raspberry pi imager.

The SD I am using is: SanDisk Extreme microSDXC UHS-I memory card 64 GB + adapter (for smartphones, action cameras and drones, A2, C10, V30, U3, 170 MB/s transmission, RescuePRO Deluxe)

I still need to try with a Mac but I don’t see much other options…

Update on this.

I believe I found the issue, this raspberry is actually quite old I believe one of the first ones… therefore I will have to check another device to set it up.

I guess this matter can be closed.


Hi so its not just me then. I also had this problem with a rip3. Flashed the SD card with rip imager. Don’t have exact specs at the moment but I can remember it is SANDisk 32GB ultra durable. I made sure to flash correct image v10 image. But would just not boot. I had a screen connected and try both mini HDMI ports. I checked my router to see if rpi comes online nothing. I flashed another card of the same type to make sure it was not a dead card same problem will not boot. I then flashed rpiOS to original card this worked fine. I then flashed latest firmware to rpi. And try homeassitantOS again still no boot. I then gave up and found a Debian image for rpi and installed homeassistant core. A lot more involved process but it works perfectly. All I can think it must be something to do with model of card maybe or current homeassistantOS image. I will update with model of card when I get the time

Also I try flashing on two different laptops (Windows & Linux)

Hi guys, @CaRoTo welcome to the forum.

So Nathan switched from HAOS to Core which did work.
Which version did you try Carlos?

I have tried HAOS 9.4, 9.5 and 10, all giving the same problem. But I simply think it’s an issue of this Raspberry pi being too old, I thought it was a PI 3 but it is a PI 1. I will probably try with an old PC.

Last version of HAOS for Pi1 is 6.x something, and a Pi 1 is way to slow to run HA comfortably.