Home assistant yellow Raspberry 4 lite with no eMMC installation with SSD boot

I just got my home assistant yellow kit and I have Raspberry Pi Compute Module 4 4GB RAM, Lite(CM4004000) so with not eMMC on the raspberry. I have Kingston M.2 SSD A400 120GB that I would like to use to boot and run the home assistant. Are there any instructions available how to do this?
I could not find a good example searching myself. I know I can install the home assistant yellow to ssd using USB adapter(which I don’t have yet), and I can use the boot loader to set the boot to run from USB but how can I set the boot to use the internal SSD or is that just USB connection?
Thank you in advance.

I did the following.

  1. I tried installing the home assistant yellow with kingston SSD inside the yellow from USB stick with the home assistant yellow image. the setup runs until it gives the error “No storage media found, exiting”
  2. I tried installing the home assistant OS installer with raspberry pie imager directly to the SSD drive with USB adapter. it installs correctly but if the SSD is inside the yellow it will not boot from it.
  3. If I connect the SSD with USB adapter to yellow it kicks of the OS installer but ends with the same “No Storage media found, exiting” error.
  4. I booted from USB with Raspberry lite OS and ran lsblk command but could only see the USB drive I used to boot the yellow not the connected SSD.
  5. I connected the yellow via the USB-c port to my windows machine as instructed and ran the rpiboot to update the CM module. The command ran fine. I did not spesify the eeprom version as I tought it would update it to a version that would have the features needed.

How ever after all of this I am nowhere near to get it working.
Could the kingston A400 be the problem for the home assistant yellow HW?
Any ideas would be really appreciated.

Here is the spesific tail of the intall log when booting from SSD via USB adapter

Welcome to Buildroot
yellow-installer login: [ 14.555500] audit: type=1334 audit(1672480270.635:8): prog-id=12 op=LOAD
[ 14.562492] audit: type=1334 audit(1672480270.635:9): prog-id=13 op=LOAD
[ 14.569294] audit: type=1334 audit(1672480270.635:10): prog-id=14 op=LOAD
[ 17.628972] vc4-drm gpu: [drm] Cannot find any crtc or sizes
[ 35.804746] cam-dummy-reg: disabling
[ 44.884955] audit: type=1334 audit(1672480300.967:11): prog-id=0 op=UNLOAD
[ 44.891938] audit: type=1334 audit(1672480300.967:12): prog-id=0 op=UNLOAD
[ 44.898881] audit: type=1334 audit(1672480300.967:13): prog-id=0 op=UNLOAD
[ 45.918448] systemd-journald[118]: Time jumped backwards, rotating.
[ 48.974257] haos-flash[257]: Getting latest Home Assistant OS version from channel stable…
[ 49.111200] haos-flash[257]: Installing Home Assitant OS 9.4 to nowhere.
[ 49.111776] haos-flash[257]: No storage media found, exiting.
[ 49.111776] haos-flash[257]: No storage media found, exiting.

just if anyone is experiencing similar issues I changed the SD drive to samsung 980 and everything worked perfect. So I assume the kingston was at fault

1 Like

Thanks for posting this. It will be helpful to many I am sure.
Looks like the A400 is not an NVMe drive and that makes a difference. As silly as it sounds, not all M.2 SATA SSD’s are NVMe. For anyone looking at booting a Yellow from the M.2 drive, make sure it is an NVMe technology drive.