Home Assistant Yellow Red light only

I have brought a Home Assistant Yellow, ver 1.3 with a CM4 and a 1TB SSD.
When I try to install via a USB I get the red light only and nothing seems to happen, even after leaving it for 30 minutes. I have verified that the CM4 is properly installed, full access to the internet and tried with and without the storage with the same result. I have tried the full reset by holding the red button but the yellow light never comes on. Running out of options as I have been through all the forums and Discord where I have tried everything. Any further suggestions, or do I have a bad board ?
Having checked the internet connection there does not seem to be any network activity at the switch, I have tried with 3 different cables and all ports. Other devices get connection and a green light but from the HA, nothing. So it seems like it is the network port on the HA :frowning:


Have you solved this issue? I got mine just now and I can’t find any simple solutions. I really want this to work but it seems like a complete pain in the bottom :frowning: