Home connect 1000 Api calls limit reached

Hey All, I have a ton of issues regarding home connect using home assistant and none of my automations regarding it works. I disabled automatic polling so that I am able to control it manually because it Will throw error and I am reloading it once Every 1 hour and 30 minutes. It still doesnt work and I am thinking about giving up on this.

homeconnect.api.HomeConnectError: {‘key’: ‘429’, ‘description’: 'The rate limit “1000 calls in 1 day” was reached. Requests are blocked during the remaining period of 84599 seconds

I am not reloading that often. I am reloading once Every 1 hour and 30 minutes which doesnt even add up close to that. I dont want to reload it so infrequently either. I want to update it much more often because i dont want The devices to wait so long to update. I am using a shell command to run and reload The integration.

Thank you

Do you use the API key yourself also?
How many devices do you have?

Home assistant is The only place that i use it. I only have 2 devices in home connect. My oven and washer.

Where do you disable the polling then?
I don’t even have that option

I cannot check if this is correct since i am unable to change The options when it is unable to setup, but if i do remember correctly, if you go to system options there should be a option for enable polling for updates.


There is no reason why the integration alone would cause this many calls.
Disable everything you have done.
If that doesn’t help then reinstall the integration.

Sorry, must have gotten it wrong. I did disabled something though and I Will get back to to whenever The error is gone so that I can take a look at The settings. I have disabled The automation for now so that it can dissapear. Thank you

After I’ve upgraded to 2022.6 i’m getting this error message too. Anything specifics you’ve changed to resolve this error?