Home-Connect failed to authorize application

Dear all,
I’m trying to set up the home-connect integration. All steps from https://www.home-assistant.io/integrations/home_connect/ are followed but when I need to authorize in https://api.home-connect.com/security/oauth/login website all the times is stating my data is wrong. I have both developer and user with the same email but different password and neither password works. Even if I ask for a new password fails too.
What I’m doing wrong?
Thanks a lot.

did integration manage to find your home-connect apps? Are they running on the same ip network?

The issue is with which username/password I must use the developer, the app one or any other I don’t know. First two have failed. Even they are right passwords stored in my password manager.
Thanks for your reply

1 Like

Are you getting something about invalid client id or redirect uri? If so, look for a query parameter with the url it’s trying to redirect to and make sure you have it listed as a redirect uri for the home connect app in the developer portal. I had this problem when I’d put the nabu casa redirect url in the app settings, but it was using the local ip address instead.

I’m having the same issue. I can’t use my username because it has to be an email, when I use my email it says that this user is not authorised to use this app. If is set my email as the default user it says that my pass is wrong.

I had the same redirect issue with the redirect URI but when looking at the address bar I noticed it tried to redirect to “homeassistant.local”. After changing that to my local IP it continued but failed with the user-login.

The USER login I was able to fix.

  • Go to the Home Connect developer portal
  • Login
  • Go to your profile
  • In the Basic Info in the field “Default Home Connect User Account for Testing” enter your email address.

Now this user can use this integration.