Home Connect integration error

Hi I am trying to connect my home assistant to home connect, when I do I first go the below error
“error”: “unauthorized_client”,
“error_description”: “request rejected by client authorization authority (developer portal)”,

Then this changed a few minutes later to
“error”: “unauthorized_client”,
“error_description”: “client or redirection URI not authorized”,

i am using the redirect URI of

  • https://*******.duckdns.org:8123/redirect/oauth

any ideas what I am doing wrong? i made sure the appliance was on and connect to the Home Connect with WiFi off at the time of adding the integration if that makes any difference.


1 Like

Hi you must configure correctly the URI:

Hi. The link in my profile is correct. but it still throws an error when setting it up. Can someone suggest how to fix this?

  "error": "unauthorized_client",
  "error_description": "request rejected by client authorization authority (developer portal)",
  "state": "eyJ############################M"

Found any solutions on this?

The integration does not work for me. For some reason I get an error after linking my HA.

but in your case, the redirect URI is wrong.

You need to enter https://my.home-assistant.io/redirect/oauth in the Redirect URIs and have My Home Assistant - Home Assistant integration activated (it is by default).

Does not work

I had the same problems, reloaded the error page where I got "error": "unauthorized_client" and then logged in with my account and then it worked. GL!

Hey guys, just solved this and sharing for future reference:

change the redirect uri from https://my.home-assistant.io/redirect/oauth to https://my.home-assistant.io/auth/external/callback

For some reason the instructions (Home Connect - Home Assistant) have wrong URL for the callback. I will make a pull request and propose a change.

1 Like

I have tried with the updated URL without luck.
Are there any possible delays or caching done that I need to think about?

Apparently, yes, it’s all a matter of caching and propagating the changes to the defined applications in developer.home-connect.com.

I don’t know how long it actually takes, but I’ve done nothing but retry for ~20 minutes and it finally worked without any changes to any settings.

1 Like

I found the URL given in the documentation (https://my.home-assistant.io/redirect/oauth) works fine.

But I had to try a different browser for it to work. Adblocker addons in Firefox probably prevented it from working.

Have tried to add home-connect integration with Safari browser. Spent couple hours and tried several Redirect URIs.
After i found this thread - changed browser to Chrome and integration started to work fine. Only last step failed, but after i changed home-assistan.local:8123 to my url added successfully.

1 Like

I’m also gettting the same error, same wth Chrome nad safari. Any other suggestions?

So if I forward the address to hir there is always an error.
that’s the list on the home assistant or.

link — 0Auth2 Authorize Callback


Thanks @t-my this worked for me!!!

I’m having the same issue.
error message bellow :

many thanks for your help and advice.

i also tried about 1 hour.
changed from chrome to edge and it worked.
i used reirect URL: https://my.home-assistant.io/auth/external/callback

I think i found a solution and the root of the problem.
I think https://my.home-assistant.io/ makes a cookie on your local computer or something to make a redirect. Automatically it uses http:// for redirecting to homeassistant.local.
If you have set up duckdns in your instance, then reqular http will not work (you can probably make it to work, but if you have followed the tutorial, it will not work out of the box). All you need to do is, click my.home-assistant link, and when it says that you can create a new redirect path, replace http to https.
This is how i managed to make it work.


I got the same error message. When I switched to a a separate browser profile, it worked. This is what I think happens:
The OAuth dance must happen with your private Home Connect account. Not your Home Connect Developer account. But since you’ve just (if you followed the installation instructions) used your Developer account to create the app, the Developer account is what you are logged in with.

So if you log out of your Home Connect Developer account before performing the OAuth dance, it will probably work.