Home Hassistant 0.103.0 vs roomba

I have just finished upgrading home hassistant to version 0.103.0 and upon reboot it no longer signals the roomba giving the following error:

ERROR (SyncWorker_17) [roomba.roomba] Error: [SSL: DH_KEY_TOO_SMALL] dh key too small (_ssl.c: 1056)

I tried to update the roomba software to the latest version but the problem persists. Has it happened to others too and if you have found a solution?

I’m having a different problem with Roomba under 0.103. It worked previously.

Error while setting up platform roomba
December 18, 2019, 11:03 PM components/roomba/vacuum.py (ERROR)


2019-12-18 23:03:09 ERROR (MainThread) [homeassistant.components.vacuum] Error while setting up platform roomba
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 150, in _async_setup_platform
    await asyncio.wait_for(asyncio.shield(task), SLOW_SETUP_MAX_WAIT)
  File "/usr/local/lib/python3.7/asyncio/tasks.py", line 442, in wait_for
    return fut.result()
  File "/usr/src/homeassistant/homeassistant/components/roomba/vacuum.py", line 106, in async_setup_platform
TypeError: __init__() got an unexpected keyword argument 'delay'

I solved it by modifying the openssl configuration like this:
/etc/ssl/openssl.cnf file
MinProtocol = None
CipherString = DEFAULT
and now it works again

I solved mine by not being a jackass and having an IP conflict.