Home location is half a mile away

I setup my home location with GPS cords of my phone.

I then have owntracks set up and showing my actual location on Maps tab.

I place the owntracks GPS cords since they were right into the cords for home location. Any idea why its still showing half a mile away for home location?

Note: The school and work GPS cords are from an example not my actual location…



Maybe your phone was reporting a bad location at the moment you took down the coordinates? Go to google maps and put the coordinates in (separated by a comma) and see if they appear at your home or at the location you see in the Home Assistant map. If it’s the latter, then the coordinates you have are wrong, and you can use google maps to get the correct ones (just click on the map).

I took home location and moved it ALOT and still doesnt show a big change.

  • name: Home
    latitude: 32.8753367
    longitude: -117.2474053

and changed to
- name: Home
latitude: 39.8753367
longitude: -112.2474053

If you go to the configuration checker, does it give you any errors? Maybe there’s a problem somewhere else. Otherwise, I’m not sure - sorry!

you’re restarting between these changes right?

Fail… I was editing the back up config.yaml and now the live one… GRRRR!

Its working now. Thanks for the help

Sorry to resurect this old topic, but I have been trying for some months now to change the defaul home location. It is still showing my original home location and we have moved since then. When I try to change it in the menu Configuration/People & Zones/Zones the default Home has a pencil with line through it which is greyed out indicatino that it can not be edited from the UI. Elsewhere in the previous version of HA I have seen it say something like the Home location has been defined in the configuration file. However I have searched long and hard through ALL the .yaml files on my system and can not find anywhere the location defined in YAML.

Today I found the above and entered that in to a new file called ‘zones.yaml’ and restarted HA but still the same and no change in the default HOME location. I have previously managed to add my correct location in addition to the default home location but these all have the ‘mdi:map-marker’ Icon.

Does anyone know how I can change the default zone.home or make it editable to change the Lat/Lon to my new location?

Thanx in advance.

I changed mine in the config.yaml . I search from my gps online

1 Like

THanx, Could you share the code that you used, as I tried pasting in from the above thread and it didnt change anything for me.

It got changed a bit with newer versions.
Anyways go to cofiguration in the GUI > People & Zones > Zones at the top > Add or edit zone.

Hi @scubieman

Yes I have tried that before but the HOME location is greyed out and not edittable:


If you can’t edit the location it is 100% defined in configuration.yaml under the homeassistant field or home is defined in general settings (Configuration → Settings → General tab).

And before you ask, if it’s defined in (Configuration → Settings → General tab), you have to move the drop point with your mouse, there’s nothing to type.

1 Like

Yes I know,

Under general it is greyed out and says its defined in the configuration file. But as I said earlier I have been through every .yaml file on my system and just cant find any reference to location.

  external_url: !secret ha_external_url
  packages: !include_dir_named packages
    - /config/www/cam_snaps


# Browser-mod
  prefix: 'browser_mod_'

# Enable Sensor History

# Enable the Default Logger
   default: info
    custom_components.webrtc: debug

# Configure a default setup of Home Assistant (frontend, api, etc)

# Themes
  themes: !include_dir_merge_named themes

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

@petro please see above, I have been through every .yaml file and can not find anywhere that the original home location has been set. Could it be anything to do with the ‘default_config’ entry in to the configuration.yaml ?

Please post your configuration.yaml here.

So just to close out my issue and possibly help others that don’t know or understand the difference between zones and locations in Home Assistant. Many thanx to @Jpsy who guided me on this matter:

your problem is that you confuse zones with the HA home location. Zones are a different thing.
Either you use the homeassistant node in configuration.yaml:

latitude: …
longitude: …
Or you use the “Configuration” menu item in the frontend and go to Settings → General.
There you can select your location from a map.
If location selection is disabled there, you are already using the entry in configuration.yaml.`

I simply replicated the following in my configuration.yaml:

  name: Home
  latitude: 52.xxxxxxxxxxxxx
  longitude: 0.xxxxxxxxxxxxx

  - name: Home
    latitude: 52.xxxxxxxxxxxxxxx
    longitude: 0.xxxxxxxxxxxxxxx
    radius: 120

FYI at-ing somebody in an edit does not notify them. I would have helped you way back in December had you just replied to my post with the configuration instead of editing it. I only see this now because it shows up on my feed after you made a post.

Thank you Petro,

No I didn’t know that, but I have thanked him directly anyway. If your point was that you didn’t reply again to me because you didn’t know that I had posted earlier with my config, then please don’t worry.
I was merely trying to close the loop, with the solution.

I see from your many posts and as an administrator, that you help many people all the time.

Best regards

Wow! I just read through this thread and I am honestly shocked how – throughout all postings – questioners and helpers seem to talk past each other.

Many questioners seem to confuse the zones list with the unique HA home location. Are we looking at some kind of usability issue of HA here?

Another takeaway is that from the very first posting on the helpers would have understood the problem correctly if only the questioners would have posted their YAML code and enough of it. They either did not or (as in the first posting) cut away the relevant lines at the beginning that would have shown the source of the misunderstanding right away.