Homeassistant and complex Network Manager configuration

I need help with my HA configuration

HA is incompatible with my NetworkManager configuration. HA has a default integration that allows it to set up your NetworkManager configuration. However, I need more options that what is provided in the UI. I have 3 interfaces and I need to set 1 to be an access point, another to share IPV4 address and a third to connect to enterprise wifi. It is not currently possible to do this within the UI under Configuration->Add-ons, Backups & Supervisor->System. So, I need to be able to control my NetworkManager configuration outside of HA. I have access to the terminal through SSH and I can modify the NetworkManager configuration. However, any time that the HA is restarted it overwrites my changes, setting the connection names to something like “Supervisor wlan0” and also removing any other settings I had in place. This did not become a problem for me until I updated HA for the first time. Essentially, all I need to do is disable the default NetworkManager integration and I will be fine.

Thank you for reading


What type of install are you running?

And why are you trying to run Home Assistant like a router and DHCP server, rather than leaving that up to your router?

Give HA one wired connection to your router and let the router take care of the other connections.

I’m running HA Supervised on a Raspberry Pi4 within Ubuntu Server 21.10. It is technically an unsupported installation, but I have had no problems so far. I have been using the Raspberry Pi as a router for my own personal network in student residence. This setup has worked fine for me for over a year. I only decided to add HA to the Pi4 after I had this all set up. The thing is I didn’t have this problem before I updated HA. My Pi4 was functioning perfectly as a router and HA at the same time for months, even after reboot. So I don’t know what changed.

Considering that the RPI4 has only one NIC what do you mean by “I have 3 interfaces”?

The only solution I can think of is to add 2 virtual network interfaces on the OS level (or if you are using the WLAN interface add 2 virtual wireless interfaces to the physical wireless card), and assign each application (DHCP server, Router, HA) one of the resulting three interfaces (the physical and the two virual interfaces).

That’s the problem with running an unsupported installation. You never know when it will break.

Sorry, I have the onboard wifi and ethernet and then a USB wifi adapter. 3 interfaces, 1 wired, 2 wireless. How do I go about assigning interfaces (or unassigning) to HA?

I have a similar problem. In my system I need two connections, one work as a wifi client and the other one as a hotspot. Till now I had no problem to switch between one to another. Now, after HA update, both connections (wifi client, and hotspot) are called the same “Supervisor wlan0” and it is not possible for me to switch to the hotspot, even if I use the UUID instead of the name connection (nmcli con up …). Is it anyway to prevent Home Assistant changes the Network Manager connections and work in the same way as before the update 2022.4.0?

1 Like

I tried downgrading to version 2022.3.8.

ha core update --version 2022.3.8

That didn’t fix it. So, I’m not sure if it is a specific issue with the newer version of HA or if the problem is that the updating process somehow awoke the part of HA that controls the network configuration.