Homeassistant andoid app

Hello, I have recently configured duckdns & letsencrypt and start getting issues accessing homeassistant from my android app.

I cannot access duckdns url from my laptop if i am connected to my wifi as i think my router does not support nat loopback.

My android application (v2.5.0-full) is having similar issue does not pick duckdns url if on internal wifi but works when i am 3G. I even tried to configure my ‘Home Network Wifi SSID’ and internal connection URL which stars with ‘https’ but i am unable to get access to UI.

I f i use browser on my phone and access internal url it works fine.

Would you know what could be issue?

ANy help will be appreciated.

Split brain DNS?

1 Like

Have you tried HTTP for internal ?

internal wont be https, only http because the duckdns cert is only valid for the external address

1 Like

thanks for your replies, no it does not work on http inside network. It has to be https (for some reason).
I have copied my config files,

  accept_terms: true
  certfile: fullchain.pem
  keyfile: privkey.pem
token: abcdef
  - mydomain.duckdns.org
aliases: []
seconds: 300


  base_url: http://mydomain.duckdns.org:8123
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

When you use the app internally you should just be using the local IP address, like http:\ or similar. Are you trying that?

yes my internal url is which was working fine before letsencrypt install.

After letsencrypt i can only use

I assume your router does not support NAT loopback? if it does just turn that on and let your router take care of the internal/external bit.