Homeassistant.components.camera.generic: Error getting new camera image


Running version 0.35.2 on a RPi3

I have a DVR on the network that can serve a static image, the url is http://x.x.x.x/cgi-bin/animate.cgi?05

I’ve confirmed the URL by browsers, without authentication and I get wget the image from the pi and can see the jpeg on disk.

My config looks like this:


Interface shows an error and logs have:

17-01-07 21:57:44 homeassistant.components.camera.generic: Error getting new camera image:

I’ve tried putting it in quotes both single and double but nothing seems to work, I tried changing the URL to another image served locally on a different box and it worked fine, the png file it loaded was on a standard url of x.x.x.x/words/here/image.png.

I’ve ran a tcpdump and I can see the request and what I believe to be a successful connection. I’m unsure where to go from here. Any help appreciated with troubleshooting this!

Could you try without “http://” ?

Also, make sure in wget you run from the pi there are no redirections - I don’t think HA can follow those.

Thanks for replying.

I tried without the http:// and now i get:

raise ValueError('Host could not be detected.')

so I’ve put that back. Interesting about the redirections as the url is to a different subnet that would of been redirected. To try and rule this out I added a network route via the redirected router and restarted (via the web interface) HA, still no different :frowning:

Can anyone else help? Does this need to be reported as a bug?

here also broken since some time but never had time to look into it

is it already reported as a bug?

Have not looked but it stopped a couple releases back here. Haven’t looked at it as the camera doesn’t serve a purpose was just a test.

1 Like

is there any other way to accomplish what I’m trying to do?

Got it working today using the mjpeg component instead :slight_smile: