HomeAssistant freezes while connecting a Zigbee Gateway USB Stick


I currently got the weird problem, that after round about 20h after connecting a Zigbee Gateway USB Stick, Homeassistant freezes and is not accessible anymore.
It is also not possible to restart only the VM. The restart process doesn’t get triggered. Only after restarting the Esxi Host, it boots up correctly and the remote console displays again.

This worked pretty fine with the USB Stick Gateway from “IT-Stuff”. But sadly, this one broke after a year.
That’s why I thought about buying this time a more expansive one.
I tried the “Sonoff Zigbee Dongle Plus -P” (also updated the firmware) and the “Conbee 2”. But both of them result in the HomeAssistant Freeze after a day. The Freeze doesn’t happen, if the USB Sticks aren’t connected.

There was also a Supervisor OS Update between the broken old USB Stick and the new ones.

I am using an ESXI Host and installed the HomeAssistant Supervisor version using the .ova file.
The System is running Up-To-Date.

The Core Version 2023.10.1 was just released.
I will test it with this version. Since there wasn’t any improvement in the last updates, I don’t think there will be a difference in this one either.

If any logs are needed, feel free to comment and I will add them. But I am currently not sure, which one might help. There was nothing useful in the home Assistant log from the Web interface.

If you have to restart the host (not the guest VM, but the machine hosting it) then that suggests there is a problem with the USB passthrough in the hypervisor. That would be an ESXI problem, but that’s pretty rugged software, so it might even suggest a hardware problem with your machine. Have you tried a different USB port or putting it on a hub?

I would like to restart the VM, but it won’t react. The console is giving me an empty Interface.

I tried different USB Slots and two different ZigBee USB Dongle.
Also, I am pretty sure, that there isn’t any Hardware Problems.

I’ve just bought Zigbee ZBDongle-P and setup ZHA and only added two IKEA devices to it so far with no issues.

However after doing so my home assistant has hanged twice, could not access the UI, and only way to get it up and running is to restart the VM. I can login to the SSH on it but reboot was hanging as well.

The dongle is flashed with the latest coordinator firmware from https://github.com/Koenkk/Z-Stack-firmware/tree/master/coordinator/Z-Stack_3.x.0/bin.