HomeAssistant is pingable, but when I try to connect it says it dropped the connection

Today I was trying to setup remote access on my rpi, so I could add HA to google home. I was able to remotely access it through port forwarding, but when I tried to setup DuckDNS something strange happened. I was able to get the add-on working and set it up. In the documentation there was a few lines to copy into configuration.yaml, which I did and then restarted HA. Soon after I attempted to connect to it, but my browser said ‘the server dropped the connection’. I tried every connection possible, its internal ip and port, the external ip and port, home assistant.local and the port and my duckDNS subdomain, all with the same results. Pinging it’s IP address works, so it’s online but I can’t connect to it any other way. I tried turning it on and off which didn’t fix it. I also deleted my DuckDNS sub-domain from my account in case somehow it was trying to connect to that and failing, but nothing has worked. Any ideas on how to connect to it again? Also, why would it go offline like that? Running it on a Pi 3B btw.

Which version of HA are you running and in which environment (virtual (venv), supervised, hassos ?..)
I am running HA in Hassos V5.13. I installed DuckDns with Let’s Encrypt to access HA remotely and securely via https (opening corresponding ports on the router to 443 internally pointing to HA IP node)… but I also installed NGINX to continue to access it locally using http://HA_nodename:8123
Can you share more information about your configuration ?

Latest version of HA. I’m not sure which enviroment, but I followed the top part of this guide to install it.

So you installe HassOS… You installed the add-on “DuckDns with Let’s encrypt” with something like this as parameters:

Than you open the port on your router by mapping for example external port 15000 to port 443 of your internal IP address where HA is installed

You access HA using : https://your_dns:15000
Your DNS (your_dns) should of course be the same than the one you used in the parameters of DuckDNS

To access HA internally without https (http://HA_nodename:8123), you have to install NGINX with the parameters like this (it is just an example):

1 Like

Thank you very much! It worked. I didn’t realise you needed to put the port after the duckDNS domain, but now that I think about it it seems obvious.