Homeassistant is sometimes an unreliable time waster

I love Homeassistant. I love how it’s growing and that there’s almost nothing that can’t be controlled. But it also becomes less reliable and less transparent.

I’d love to know if you feel the same way. Or do I just want too much? Is my system with 1119 sensors and 177 switches and 40 lights too big?

A few examples:

  • The lovingly put together HomeKit Bridge configuration can no longer be shared with other users in iOS. Searching a solution for days.
  • My LILYGO T5-4.7 ink screen, which used to work without any problems, no longer works because an ESP Home update has changed the display function. None of the available ESPHome integrations work anymore. Took me days to find the reason, but I can’t fix it.
  • I deleted the iCloud integration at some point because I was constantly being asked for the code but couldn’t enter it anywhere (I now use iCloud3 v3). Had to edit all automations and dashboards
  • The Husqvarna integration, which has now been added to the core, does not work as expected. “Start Mower” does not start the mower, it just activates the mower’s schedule, which may not start the mower again until tomorrow. Took me ages to figure this out.
  • The frontend integrations (I admit, I also use some from HACS) are not very standardised. Some allow this, some allow that. You have to dig through the documentation every time because there are no standards for frontend YAML (styling, scripting capabilities, etc.).

These are just a few of the things that are costing me a lot of time right now. It’s a lot of work to keep a large system like mine running at all, let alone expand it. But it’s supposed to make life easier.

I feel you bro, but yeah… it is what it is.

1 Like

That’s not a small setup. Depending on what you are asking it to do with all of that may require much more hands-on and work.

This works for me without any problem. Regardless, that’s an Apple issue and not an HA issue. In fact I have several HomeKit homes shared and I haven’t had a problem. Try resetting your HomeKit, it could be that you have a corrupt database (again, Apple’s issue).

That’s kind of the point, in my opinion, to have things that break away from the established standards to give you a different experience. This is what makes open source flexibile.

I have a very complex home in HA and I also spend a lot of time managing it, but as I have matured in my use of HA and my understanding of how I can better tweak it, I am making it smarter every time I can. For instance, I had a dozen different systems for controlling curtains, so I wrote a single script to do it all for me 100% automatically, I made it smarter and it takes less time to manage now.

Bear in mind that part of the issue could be HOW you have implemented things.

I disagree that HA is unreliable, we MAKE it unreliable by adding tons of crap to it (guilty as charged for me). It can be a time waster or a time sink, or it can just automate a few things and not be as complex and require nothing further from you. The choice is totally yours.

1 Like

I disagree that HA is unreliable, we MAKE it unreliable by adding tons of crap to it (guilty as charged for me).

:grin: True.

Try resetting your HomeKit, it could be that you have a corrupt database (again, Apple’s issue)

I did it already. Two times. No improvement.
Still working on HA bridge HomeKit does not working when sharing with family members · Issue #110540 · home-assistant/core · GitHub and HA bridge HomeKit does not working when sharing with family members - #16 by slawekb

That’s kind of the point, in my opinion, to have things that break away from the established standards to give you a different experience. This is what makes open source flexibile.

Yes, but it should work like it worked in HTML or CSS and its Consortiums. All the (reasonable) possibilities that have been created in HACS should gradually be moulded into reasonable rules that everyone can then follow. Standards, in other words.
And even if there are standards like the lawn mower entity, even core integrations sometimes do not follow it.

There’s reset, and there’s reset. Resetting HomeKit in HA does nothing more than just send new data to your actual HomeKit. Resetting in on your phone fully blows away HomeKit and starts over. I was referring to the second, if you haven’t tried that yet.

I built out the entire HomeKit platform for a competing home automation system and in the early days of HomeKit and less frequently today the database would just corrupt. I set up HK from scratch probably two dozen times before Apple stabilized it. I haven’t had an HK issue since.

There’s reset, and there’s reset.

I deleted HomeKit from HA, restarted HA, deleted all homes from HomeKit/iPhone and reset HomeKit on the iPhone with the following profiles
I reinstalled HomeKit in HA, added the Bridge via QR to HomeKit on iPhone and still the „Invite People“ button is missing. Did I forgot something?

BTW: I don’t have a Apple hub, but I think that’s what HomeKit Bridge is made for and Apple says:

If you set up a home hub, you can manage remote access and edit permissions for people that you invite to control your home. If you don’t have a home hub set up, they can only control your accessories while they’re at your home, connected to your home Wi-Fi network, and within range of your accessories.

Yes, you have to add a home hub, meaning an Apple TV or HomePod that can broadcast the HomeKit outside your house. Have you added one of those to your Home in iOS?

No, I don’t have an Apple hub. I’m sure that it already worked before without a hub. I was convinced that the HA HomeKit bridge WAS the hub/bridge. I found a lot of people that have had the same experience.

And even Apple says that you only need a hub if you want to access your home from outside.

100% disagree on unreliability.

Time waste, depends on you. I’d say it’s time-consuming digging through docs, testing, setting stuff up and maintaining it so that it works solidly. Once it does, shoot and forget.

Over time I’ve done the same as Four Wheeler and consolidated complex sets of automations into modular scripts that focus on carrying out small tasks reliably.

I agree on the unreliability only in that some vendors break things from time to time, and my own stupidity in the way I do things. As I have learned I have rewritten things to be more reliable, sometimes I can write code around vendor issues (such as an automation to cut and restore power to a Yolink Hub monthly, to reboot the RPI4 twice a week, even writing things such as two different ways to connect to some sensors and using both as triggers in case one or the other does not work (such as Yolink integration and also with Yolink sensors through IFTTT) or, the Ring integration and then als using Ring-MQTT Add-on both as triggers.

Also the reliability of your system will grow over time once you stop adding a gazillion things and go back and fix what isn’t working well. Sometmes that rquires throwing things away and buying new hardware as you learn (such as replacing a bunch of Wemo smart plugs with Shelly smart plugs, and replacing Wemo light switches with Leviton ones that support Matter.

Just keep fighting the good fight and concentrate and work more on reliability sometimes instead of working more on adding more new stuff. Easier said than done!

I have about 350 automations and 150 devices, with an RPI4 8 Gig running HA Supervised with Debian 12 using just an SSD for the HA storage. It was pretty buggy but now has no issues most of the time. I keep my automations versy basic and simple, but write alot of them, which I believe makes it alot easier to maintain. I also have everything set up in the home so that it can be done manually as though there is not automation so it doesn’t not disrupt life if there is an HA issue. Periodically I shut down HA and competely clone the SSD from time to time. You MUST use the google backup add-on as well and have it do automatice backups of the HA configuration. Those have saved my ass more times that I can remember. Both from a bad update from a vendor (so go back to a previous version and watch the forums to see when they have fixed the problem before upgrading), as well as a massive mistakes I had made while learning (low level stuff in the OS like daemons that screw up and destroy the whole thing!). If the SSD dies I can just plug in the backup SSD, and I am up and running in only the time it takes to do a reboot and then restore the latest HA Google backup for recent changes I have made to HA that were not already cloned onto the other SSD. I bought an RPI5 but am not using it, as I want to add video and am patiently deciding how to spproach migrating in that direction, I am sure I will need more robust hardware. I know there is better hardware out there, but I have fallen in love the the RPI paradigm. I knoew it’s stupid, but I don’t want to give it up!

This is one of the only instances where the pressure to keep a high WAF rating helps to improve the reliability of these setups - those that are able to survive the onslaught. I still think it’s not fair that you need 1,000 things done right to make up for one ‘oops’, but such is life.