Homeassistant.local access - IPv4 vs IPv6?

Hi Community,

New HA user here (OS on RPi installed last week). I’ve managed to set up remote access via CloudFlared and currently have set static IPs in the HA config.

All was working well until this morning, when access to homeassistant.local appears to have stopped working on my mobile phone (connected to local network)

I am still able to access from a second device on the network and have found that this is using the IPv6 address when pinging homeassistant. Pinging the IPv4 address fails (despite being able to see the address allocated on my router). I therefore believe this is why my android mobile is unable to connect.

I’m at a bit of a loss now, and google has been unable to help me, so I think my question is… What have I done to break the IPv4 address, and how do I get it back working again?

Sorry for what might be a very newb question, and many thanks in advance for any advice you may be able to offer.


1 Like

Let’s start with… What is the IP (v4) config yow think you should be using on the HA box, on the client device you’re pinging from and what they actually are.

(and if you’re using private ip ranges 192.168.x or 10.x addressing don’t worry about reacting the internal. Ip addresses - nobody cares about your internal IP address schema and we’ll need to see all the numbers to know whats going on. Please do however redact any keys or pass code.)

So ha:
IP address:
Subnet mask
DNS server


And what the network gear is between them.

Thanks Nathan,

HA (info from HA network settings)

Client (info from “ipconfig /all”)
Subnet Mask:

The router is a BT Hub 6 and I can see both devices listed as connected with the IPs above in the hub config.

Thanks again.

Your netmask is a problem on the HA box
/32 means that if you expand the IP address out to binary then 32 digits of the address neetldnto match (from left) for two addresses to be on the same network.

Basically hes in a network of one by himself…

Your client box is on a network defined as which translates to /24 in CIDR

(and what I expect in a home network)

Change the netmask on the HA box to /24.

1 Like

Nathan you are a star! That has worked perfectly and HA is now accessible from all devices on the network.

Thanks once again for your help!

1 Like

Awesome! glad it works. Don’t forget to mark the solution post for others.

1 Like

I have the same issue.I cannot connect to my homeassisten with my ip at all.I have plugget all the devices from the same access point. But this setup doesent work in mine home assistant.What is this the same on all homeassistant? I have typet in my suppliers ip adress and my homeassistant ip adress. Is it on the endo or wlano this shoult be typed in?? The ip adresses that is on the lines in setup in HM when in setting, i cant find anywhere.This is something automatic i think??

Hi guys,

I have a similar issue where I had the need to change my mask to to have more clients available in the network I changed the sub mask in HA accordingly to /26 however no the HA is connecting via IPv6 and I can’t get it to get back to IPv4.

Could you please help?


What was your subnet mask before the change?
When you changed the mask, did you set the mask to be the same for all the devices on that same subnet?