Homeassistant update to 118.5 from 107.5 issue

Hey all,

I noticed I was due for an update on my docker homeassistant setup. I click on update and it sat there and spun for a bit. I then lost access to the UI.

Docker ps shows the following containers running:

Docker image ls shows two homeassistant images but I can no longer run docker start homeassistant. The name no longer exists.

Here is my docker image ls output

How do I link the homeassiant name back to the image I need?

Firstly, how did you update? Through the HA UI, or using something like Portainer?

Secondly, what underlying OS are your using? Ubuntu, Debian…and did you also update the OS?

Last, you will most likely have a lot of breaking changes that will need to be addressed. Some of these may prevent your instance from starting. Did you check through the 11 versions of breaking changes against your config * before* updating?

Yes I went through the HA UI. OS is CentOS 7, no update to the OS. Been running fine for about 10 months, first update in a while though. As for poking through the 11 versions of changes, I did not. Since the 107.5 image is still there, anyway to fire that one back up and have it work, or did I pretty much shoot myself in the foot on this one?

Sigh… So my whole setup now is broken and I’ve tried pulling in the older 107.5 image, however its now giving me a bunch of errors. I should have just left well enough alone. Whats the best way to get back up and running? Reinstall can try to add my config files or do I have to start from scratch?

Hopefully you took a Snapshot and saved it before hand? Regardless, connect to the machine via SSH with something like WinSCP, or Samba if you have that running, and backup all your .yaml files.

I might be quicker and easier to re-install HA from scratch and might be a good opportunity to move to Debian as the OS as CentOS is not a supported OS.

If you want some help getting Debian 10 and HA Supervised installed, you can check this guide

Nope, no snapshot. I run to much other stuff on this host to switch OS. I guess I will tinker with this as it seems like all other containers are running, just not the homeassistant one. I will see if I can cobble it back together. If I have to re-install. The .yaml files I need to back up are in /usr/share/hassio/homeassistant

I found if I manually run:
docker run --expose=8123 --name=“home-assistant3” -v /usr/share/hassio/homeassistant:/config homeassistant/qemux86-64-homeassistant

I can get the new homeassistant docker image to run, but man there are a lot of errors and I can’t control my lights or alarm system.

The old image at:
docker run --expose=8123 --name=“home-assistant4” -v /usr/share/hassio/homeassistant:/config homeassistant/qemux86-64-homeassistant:0.107.5

That image wont even run anymore.

Please confirm I only need to back up /usr/share/hassio/homeassistant dir to try and salvage anything. I take it I’m going to have to re-write and re-work every thing I have working with the new release?

Yep. I screwed up my OS a few times and had to reinstall it. I’m using manjaro. Just copy that dir to another folder, remove all ha related docker containers, remove the supervisor service and/or remove, if possible, anything related to docker.
Then rerun the install script and copy everything back. Then restart ha.

Thanks tenn0,

Well, I managed to get a newer version of the Home Assistant docker container up and working… Version 0.119.0.dev20201211 to be exact with out having to reinstall. I now see what Home Assistant does on the backend when standing up the docker images. Once I loaded my Zwave stick, USB device and figured out the correct network I managed to get all my lights back up and working. The old Concord security system is back up and I just got my lovelace-animated-background backgrounds up and working again. Not what I planned on spending my weekend doing. I’m 95% back up and working. Just need to make sure my Pentair pool controls work and get the Night owl Transparent theme working and I have what I had working. Man, a lot has changed since I last upgrading. Having the UI to configure everything is nice, still figuring out where to click. I was pretty well versed with the .yaml configs. None the less, I appreciate all the feed back on borking my system up. I think I’m progressing nicely. Oh, and Portainer was a nice addition to manage the images.