Homeassistant working then Update messed me up

Just for reference, I have my raspberry pi connected to my TV via HDMI cable and have a wireless mouse and keyboard connected to it when I used it previously as a plex server. Anyway, I installed an older version of home assistant on raspberry pi 3 today and got everything up and running fine. During the set up of my integrations I noticed it said update to newest version so I clicked on it. It started doing the update and disconnected me from the web interface on my laptop. When it restarted, I noticed it stopped at the screen saying login username. I typed in the username and password I set up when I set up the system using the web interface and it said incorrect credentials. I figured I did something wrong so I continued to enter different usernames and passwords. I tried every combination I could think of but nothing. Anyway so I decided I will just bite the bullet and do a fresh install. I formatted the SD card, reflashed the software and popped the SD card back into the pi. Turned it on and let it do its thing and got the same results asking for the username and password. I figured it might be the card so I got a new card and went through the same steps with the same results. Then I decided to try the install on a virtual machine. That was a chore in itself but I got it done only to end up with the same results. Any solutions or suggestions are welcomed. I have a great deal of patience so I don’t mind reinstalling and whatever to get everything working but I am a brand new newbie to networking and open source and linux and python and coding and whatnot so if you have any info please keep that in mind. I tried searching the forums but couldn’t find any results that matched my situation. I even tried going into the command line I guess (black screen with all the white words and codes that scroll really fast) to try to figure stuff out. I tried to reset the username and password (ha auth reset --username etc…) but that came up with an error saying try supervisor. I’m lost and stumped and a bit frustrated. Please help.

So many words and yet so little information :joy: Why install an older version of HA? Follow the getting started instructions, if you run into issues report exactly at which step of the process.

Thanks for the comment sjee. I know it was a bit wordy but I had downloaded a version of homeassistant to start the project before summer but never finished the install. So when I jumped back into it yesterday I just continued from there. And by the way I did follow the steps in the getting started instructions. Like I said I had it running until I did the update within the web interface. The problem happened during the reboot after the “update.”

Yeah, I understand but since then you have formatted the SD, etc. so not very usefull to try to figure out what happend. Just flash the correct image and take it from there.

All other installs on the subsequent SD cards were of the most recent correct image, even on the virtual machine.

Not sure how to help if you do not tell at which step things go different from the getting started instructions.

Okay I will try the install again from the beginning with a fresh SD card and a fresh download of all software and images. Maybe I’ll have better luck today. Thanks.

So I did a fresh install of the image for Raspberry pi after formatting the SD card and loaded it on the pi. It booted up and after about 5 mins I got this message in the command line

After about 30 mins I got this
After about an hour I got this
I went online to try to access the web interface and got this

This is exactly what I got yesterday but I decided to take pictures today. Hopefully this helps.

homeassistant.local, or IP address (as stated in the getting started), hassio.local does not exist


and tried

Could it be that because I had a version of Homeassistant running on my network before, it won’t let me install a new image without the username and password of the original one?

Hi, I have a similar issue, after 2 day’s installed 5.90 via Update function in Hass.io I can’t reach the webserver. Login via Shell is still possible. Issue after update 2 days ago

Regards Michael

I can go no further with set up or anything as I cannot get back into the system. I kinda just gave up and put it on the back burner for now. Hopefully there’s another update soon that I can download and try that.

Same here. I tried to recover from snapshot and when I was back from work, I found it is not working again.