Homeassistant yellow refuse to boot, red led only


i just got my home assitant yellow. I pluged it in and got a web page with a wait screen, 28h later it was still locked in this wait for 20 min to install.

Therefor i proceded to several reboot with no better outcome. I then proceded to reboot using the usb reinstall procedure. Since then the home assistant yellow is a brick that only lit the red ligth. At boot there is 4 quick flash. Whatever i do using a usb key or other the HAyellow just stay like that and stay with the red ligth.

So it was not working and is basically a brick with a led right now. I took the Yellow Kit with Power Supply. The FAq speak about a jumper but my unit do not have it, it has a button for usb recovery.

Anyone know how i could try anything to recover it ?


Power off, open it up. Make sure all of the components are seated and the jumpers are in the correct place.

Some docs to read:

well i had read this and there is no jumper here but a button so it is not connected (yellow rev 1.3). I rebooted billions time trying everything with a usb stick constructed following this explanations


well i cannot say i am not a little dispointed :frowning:

Okay can you attach a pic of the top of your board, that way I can compare to mine.


thanks for helping here :slight_smile:
here is the pictures

i dont find in the official doc what is the use of the usb/uart jumper nor the buttons, I know blue+red reset the Yellow, seems the red alone do a wipe of the data partition but this is only guess from googling the doc explain nothing.

the way i see it is that the Yellow is stuck in USB mode and dont want to reinstall.



i tried option 2:

the ripboot works, the piimager write the os and it boots with lashing light. I then waited 2h ( just in case i am on 700mbps internet access). The red ligth was on and i had blinking green one (no yellow) .

at last i got the usb debug serial on and saw that it was unable to resolve


i can from the console resolve many other domains with no issues so i added github.com and objects.githubusercontent.com. to /etc/hosts and launched the flashing by hand and it succeded.

so for a reason that i cannot explain the flashing failed because it cannot resolve two domains github.com and objects.githubusercontent.com

now the page loads and i am back at
Preparing Home Assistant

and ha logs show

23-03-15 11:38:22 INFO (SyncWorker_0) [supervisor.docker.interface] Updating image ghcr.io/home-assistant/yellow-homeassistant:landingpage to ghcr.io/home-assistant/yellow-homeassistant:2023.3.4
23-03-15 11:38:22 INFO (SyncWorker_0) [supervisor.docker.interface] Downloading docker image ghcr.io/home-assistant/yellow-homeassistant with tag 2023.3.4.
23-03-15 11:38:22 ERROR (SyncWorker_0) [supervisor.docker.interface] Can’t install ghcr.io/home-assistant/yellow-homeassistant:2023.3.4: 500 Server Error for http+docker://localhost/v1.41/images/create?tag=2023.3.4&fromImage=ghcr.io%2Fhome-assistant%2Fyellow-homeassistant&platform=linux%2Farm64: Internal Server Error (“Get “https://ghcr.io/v2/”: dial tcp: lookup ghcr.io: no such host”)
23-03-15 11:38:22 WARNING (MainThread) [supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30sec

in a loop… :frowning:

i was able to make it work again by using /etc/hosts. All the domains i test resolves fine but it seems that all github related are failing for unknow reason. i had to add pkg-containers.githubusercontent.com

right now i have no confidence that the system is installed as it should :frowning:

Strange that github is not reliable and causing the issues you are experiencing. Just by chance did you create a account for yourself on github?
Since you had to add it manually, where was that done? Router or HA?

well i could resolv it from my computer so i just did a dig github.com on my computer, then add on the hayellow from the console login github.com objects.githubusercontent.com pkg-containers.githubusercontent.com

in /etc/hosts with the ‘vi’ editor. Same for the others domains. It does not seems an issue with github and resolving was working for genuine domains i tried like google.com, tf1.fr or others.

i really dont know why it was having issue here. Just by adding the rigth hosts in /etc/hosts i made it work.

i have an account in github but this is not linked to anything that happenned here so, no link.


ps: note that the ip used are the ip at the time, github ips can change so dont copy paste that if you have the same issue you want to test the ip at the time with nslookup or dig :stuck_out_tongue:


I just received my HA Yellow and I’m encountering this issue. I was able to follow the process but I got lost after the blinking green, and red light, no yellow. I do not understand what you did next to resolve the issue. Can you please enlighten me? I tried clicking on the github links on this trail of replies but I’m just prompted to the github home page… Help, please :frowning: