Homebridge default visibility

Hey guys,

I have homebridge set to default visibility to be hidden, but it’s not working. I have to go into my customize file and hide each and every item that gets exposed to Homebridge, this is everything from sensors to groups and automations. It’s kinda annoying and I have no idea why it’s not using the default visibily setting.

This is my config.json for Homebridge. Any help would be appreciated.

“bridge”: {
“name”: “Homebridge”,
“username”: “CC:22:3D:E3:CE:30”,
“port”: 51826,
“pin”: “031-45-154”

"description": "HomeBridge HTTP Status Control",

"platforms": [
         "platform": "HomeAssistant",
         "name": "HomeAssistant",
         "host": "<removed>",
         "password": "<removed>",
         "supported_types": ["automation", "binary_sensor", "climate", "cover", "device_tracker", "fan", "group", "input_boolean", "light", "lock", "media_player", "remote", "scene", "sensor", "switch"],
         "default_visibility": "hidden",
         "logging": true


Try to remove “persist” folder in homebridge location , and then restart HB.

that didn’t work.

I even uninstalled homebridge from npm and the homebridge-homeassistant addon for homebridge globally from my pi, and rebooted and reinstalled both.

Even having “default_visibility”: “hidden”, from the get go, it still lumped all devices into Homekit. I now have over 64 devices mostly groups, automations and other silly items to hide.

I don’t know what’s going on. Something weird.

Done some more investigating today. Ended up all homebridge components and re-installing a few times. Seems there are a few files that are not uninstalled and were causing issues in the new install. Mainly having devices show up when there is no platforms setup.

Anyway, I now have default_visibility: hidden working, but now I have no devices at all. I have the homebridge_visible: true tag there, but it’s just not working.

No idea what’s going on now…

Please , paste some config from yours customization.

This is from my customize.yaml file

friendly_name: Temperature
homebridge_visible: true

Is this yaml file is included in main config of hass ?

yes, I have much much more in there. lots of other devices with friend names, icons, etc. this is just one device I’m trying to use with homebridge. it was working when I had everything visible, but my customize.yaml file was getting rather big, so i swapped it around. now everything is hidden as expected, but I can’t get anything exposed.

Oh, OK. So try to remove “persist” folder from homebridge location , then restart HB.

That didn’t work. I’ve tried it before.

I’ve even removed and fully reinstalled both Homebridge, and the Home-assistant addons for Homebridge.

I had simmilar issue:
Remove HB from HomeAssistant , and pair again. If You are not be able to find home bridge, please check port availability which is used by homebridge or change it for diffrent one.

how do you remove it from HomeAssistant? I know where the HB config is and get remove HA from that, but do you mean to remove HB from HA?

Sorry for this. Mean HomeKit in iOS.

yep, removed the HB device from my phone.

Is it works now?

hmm, i think i may be on to something. totally unrelated to the persist folder though…

somehow in the config.json for homebridge, and comma “,” had somehow ended up at the end on the “logging”: true line. I’ve removed that and it seems to have started something to work. Not fully yet though. Funny enough it wasn’t there on my first post above. Not sure how it got there.

Actually, I’ve just rebooted my Pi3 and it seems to be working now. Seems that this extra comma was the culprit. Easy to look over as every other line has the comma.

Thanks for all your help buddy.

I’ve got the same issue as @cjsimmons had. Altough I haven’t got any extra comma or something. This is my code

  "bridge": {
    "name": "Home Assistant",
    "username": "B8:27:EB:47:45:1B",
    "port": 51826,
    "pin": "XXX-71-924"
  "description": "Homebridge for Home Assistant",
  "accessories": [],
  "platforms": [
      "platform": "HomeAssistant",
      "name": "HomeAssistant",
      "host": "http://hassio/homeassistant",
      "password": "",
      "default_visibility": "hidden",
      "supported_types": [
      "logging": true,
      "verify_ssl": true

In Customize I’ve got

  icon: mdi:lightbulb-outline
  homebridge_visible: true
  icon: mdi:lightbulb-outline
  homebridge_visible: true

These two switches won’t end up in Homekit. I’ve tried reboot, remove the persist folder, re-install, etc… nothing works

What a mI doing wrong?

Do you have any other devices working in Homekit? If not, are the host and password fields correct? Failing that, I can’t see anything wrong.

Which host- and password fields do you mean?
I see the homebridge accessory, but that’s all…

under platform, there is a field called host, and a field called password. Host is filled with http://hassio/homeassistant, while the password is empty.