HomeKit breaks in 0.67

Had HomeKit running wonderfully under 66.1, no issues. Upgraded to 67.0 and it’s broken,

To fix needed to delete the config file, restart, re-add, and re-create the automations…

I upgraded to 0.67 this morning and haven’t noticed anything. I only expose two input_boolean devices that I use for presence, but they seem to be working under 0.67.

I didn’t need to delete the config file but I did need to sort the home page out again. With a lot of switches & sensors this takes a long time to sort out again.

I spoke a little soon - I don’t know if it’s related, but my HomeKit Automations all got listed as “Disabled” in the Home app. It turns out the switches were no longer selected in the automations. I wonder if they changed homekit id’s or something?

The switches still showed in the home app, and they still worked, just all of my automations had “nothing” selected for the actions. Anyway, once I went in to each automation and re-selected the switches for them, everything worked again.

Mine wouldn’t talk to the HA bridge any longer and all devices showing as unresponsive.

Have you tried deleting the hidden file .homekit.state then restarting HA ?

I have now filtered mine to included only the entities that I want, with a delayed 1 minute start using an automation. I configured mine again this evening in a few minutes with all the unwanted entities hidden

  auto_start: False
      - switch.tv
      - switch.lights
      - switch.fireplace
      - sensor.water_temperature
      - sensor.dark_sky_temperature
      - sensor.hallway_thermostat_temperature

  alias: 'Start HomeKit'
    - platform: homeassistant
      event: start
    - delay: 00:01  # Waits 1 minute
    - service: homekit.start

Does it work for you now?

For me it works for a couple of minutes but then the Home app shows all my light not responding. Set everything up a couple of times, also deleting the homekit file. No luck though…