HomeKit Bridge "Accessory Not Found"

Tags: #<Tag:0x00007fc3ff0857f8>

Earlier today, I migrated from my RPi4B running RaspbianOS to the new ODROID N2+ Blue!
Booted it up, and made a restore from my backup from the RPi4B.
Apple Home would now not work, and I would see “No Response” on my AppleHome.
Figured it had to do with the service starting before devices are available, so I modified my “configuration.yaml”:

homekit:
  auto_start: false
  filter:
    include_domains:
      - light
      - switch

Then I added the following to “automations.yaml”:

- alias: 'Start HomeKit'
  trigger:
    - platform: homeassistant
      event: start
  action:
    - delay: 00:03  # Waits 3 minutes
    - service: homekit.start

No errors according to the “Configuration Validation”, so I went ahead and rebooted!

Bam! Now I had 2 HomeKit under Integrations!
Removed both, and restarted again! Now after reboot, it took about 3 minutes before the QR-code notification came up. Great I thought! It must now work as intended!

Removed the integration in Home on the phone, and tried to re-add it, like I have done several times before, now I get “Accessory Not Found”, and it will not integrate!

Have tried rebooting the router, the Wifi-hotspots, the phone, disabled adblocker on the phone, rebooted the ODROID N2+ (new QR code) still same error, “Accessory Not Found”.

Any idea on how I can get this to work? Troubleshooting hints?

Any hints?

I’m facing the same problem, any solution?

Nope, still have this issue, and the family is getting pissy, since they can now not use Siri to turn lights on/off anymore! Getting really annoyed, and are thinking about moving back to my RPi! Here I thought the Odroid would be better supported!

Ever find a solution. Having almost the exact issue today.

Found the setting! It is called “Auto-optimize Network”, and can be found under “Settings” > “System Settings” > “Advanced Preferences” in the “Unifi Network” app on iOS.

After disabling, I can now add my devices in Homekit again!

What does that setting do?

I don’t use that OEM and am looking for a similar setting on my gear.

Thanks.

See here: https://community.ui.com/questions/Auto-Optimize-Network-Any-explanations-or-guide-somewhere/a05cf6ec-04d5-4c7c-a878-f6cbfc41192d

1 Like