Homekit Camera Aqara G2H with secure video

Is there any good news about G2H intergration?

World ne also interested in this…are there any News ?

Still not able to make it work efficient.

I found some new information, but dont have time for test it: GitHub - niceboygithub/AqaraGateway: Aqara Gateway/Hub integration for Home Assistant

Hello everyone!

I’m trying to integrate G2H to the Home assistant according to the instructions GitHub - niceboygithub/AqaraGateway: Aqara Gateway/Hub integration for Home Assistant.

It says that you need to activate telnet on the device using the hostname file with the content:

passwd -d root
echo WITH_TELNET=y >> /etc/.config

Then you need to connect via Putty telnet to the device. But I can’t connect …

Next I installed the custom_component Aqara Gateway/Hub, which at the first start saw the device and offered to add it, but when added with an empty password, an error pops up.

Who can advise what? How can I contact the author of the integration - niceboygithub?

Same for me.

Good evening,
i’managed to put the G2H into home assistant with the Homekit controler integration, but I can only watch live, detect a movement or take a snapshot…I can’t record…
has anyone managed to integrate the G2H so that recording becomes possible?

How did you manage that? I turn on the homekit controller integration, but it doesn’t see G2H.


You have to make sure that the G2H is not connected to the Apple homekit itself. (the camera can only be connected to one thing)

I would reset the camera (with the pin at the bottom)
then i would restart it and make sure that if the aqara app asks you to integrate it into apple homekit, decline it.

If you then go back to the home assistant (maybe that one reboot has ndoig), the homekit controller should normally detect your camera as a new device, and you can further integrate/set up the camera from there.

I hope it works, if something is still not clear, feel free to ask.


I am new to adding G2H in HA but I was wondering if you could integrate the camera with frigate or motionEye and using this be able to record the video?

Hi NBG, Ii’m not familiar with frigate, but motionEye didn’t work for me…

Hello everyone. There is good news: Aqara is making a component for integration into HA. It is called Aqara Bridge.

But I couldn’t get it to work, when adding the integration of this component, an error is issued.

Hopefully they will fix it and finally it will be possible to integrate G2H.


Hello everyone. If anyone is interested: AqaraBridge has appeared in the repository https://github.com/niceboygithub/AqaraBridge. The description says that for the component to work, you need to register at Aqara 开发者平台 -Iot开发者平台 and wait for the account confirmation for several days, after which it should work. I’m registered and waiting.

But i don’t know where and how to integrate my Aqara IoT Cloud account into HA. Can someone tell me?


So - for some reason, my Camera just started to be very responsive with my HA setup.
I made a new clean setup of it, following @Allbruce’s instructions. Hereafter, I installed the new version from the Aqara App to the device, and then it runs like a charm.
I hope it will work good for you too.

Did you manage to get it to record also? As far as I understand @Allbruce struggled with this but maybe the issue has been solved?

The way I use it in my setup, is that I have the camera in my dashboard, automations, and etc.
However, the recordings are saved on the Aqara application automatically. So this is where I find my recordings. :slight_smile:

1 Like

So a trigger in your automations causes the camera to record and the recording is then saved in the Aqara app if I get you right?

thanks Allbruce. The integration works. However, I’m running into another annoying problem. In my Lovelace dashboard the height of the image changes. The image is getting smaller and smaller. (less high). Do you have a tip with the solution?

What about the Zigbee 3.0 Hub integration?

Record was not possible…so i went back to apple homekit and now use the secure video feature. I don’t want to record in the aqara app…