HomeKit Controller - Integration randomly failed to connect

I’ve had a HomeKit Controller based integration working for quite some time (connected to a Polypipe Smarthub) and its been working flawlessly.

Recently it failed to connect with the following error:

2022-09-29 08:58:21.882 WARNING (MainThread) [homeassistant.config_entries] Config entry 'Polypipe SmartHub' for homekit_controller integration not ready yet: Timeout while waiting for connection to device; Retrying in background

That IP address is not the IP found in the configuration file and removing the configuration in core.config_entries: (pairing data removed for this post, but it is correct)

        "entry_id": "68d13588bf24a3f3a0e801d539ebdd98",
        "version": 1,
        "domain": "homekit_controller",
        "title": "Polypipe SmartHub",
        "data": {
          "AccessoryPairingID": "85:B1:51...",
          "AccessoryLTPK": "83c42eb72cf60a6e324d...",
          "iOSPairingId": "b783c4fc-c7ca-4e0e-...f",
          "iOSDeviceLTSK": "9d3fa62d3b761b49f40afe6cb...",
          "iOSDeviceLTPK": "40ba2bd7fc8eec8e6d2a01d6...",
          "AccessoryIP": "",
          "AccessoryPort": 4238,
          "Connection": "IP"
        "options": {},
        "pref_disable_new_entities": false,
        "pref_disable_polling": false,
        "source": "zeroconf",
        "unique_id": "85:b1:51...",
        "disabled_by": null

If I remove this entry, reboot the device, re-add the config and reboot the config works again for a period (a few hours maybe).

The Polypipe kit is up and working, pings fine and everything is up as far as I can tell. Not really sure what else to try? Any help would be much appreciated!


Some information regarding my config:

Home Assistant 2022.9.7
Supervisor 2022.09.1
OS 9.0
Frontend 20220807.2-latest

Running on a Raspberry Pi

Regards, Daniel

Anyone got any ideas? I’ve tried disabling it for a while then re-adding it but still get the same problem

I just started having this same issue with my ecobee thermostat. The regular ecobee integration works fine, but I like using the local homekit control since it adjusts faster. Haven’t upgraded anything recently either.

Did you ever figure anything out?

It simply started working again in the latest versions so it appears to have been fixed; at least from my end. Sorry!