Homekit Controller not working correctly

Hi,
I’m struggling with the Homekit Controller.

  1. I have only one “only Homekit” devices. Thats a Nanoleaf Smarter Hub with four simple dimmable bulbs. Its working nearly perfect with homekit for years.
    Activated the Controller in the Configuration.ymal and Configured the “Nanoleaf Smarter Hub” via Web UI with the homekit PIN. But instead of four lights, I only get one “light” entity witch did simply nothing…

What is wrong? How can I remove the Hub from HA?

  1. I see a second configurable Homekit devices.

What its that? Is the Homekit Contoller detecting the Homeassistant Homekit component? How can I dismissed that?

Thanks for helping

I see this in the log:

Updating homekit_controller light took longer than the scheduled update interval 0:00:30
20:37 helpers/entity_platform.py (WARNING)
Updating homekit_controller light took longer than the scheduled update interval 0:00:30
20:37 helpers/entity_platform.py (WARNING)
Updating homekit_controller light took longer than the scheduled update interval 0:00:30
20:36 helpers/entity_platform.py (WARNING)
Updating homekit_controller light took longer than the scheduled update interval 0:00:30
20:36 helpers/entity_platform.py (WARNING)
Updating homekit_controller light took longer than the scheduled update interval 0:00:30
20:35 helpers/entity_platform.py (WARNING)
Updating homekit_controller light took longer than the scheduled update interval 0:00:30
20:34 helpers/entity_platform.py (WARNING)
Update of light.nanoleaf_smarter_hub is taking over 10 seconds
20:34 core.py (WARNING)
Update of light.nanoleaf_smarter_hub is taking over 10 seconds
20:32 core.py (WARNING)

no ideas???

still having this problem :frowning:

I can configure the accessories but are not seen on the front end.
Help please