Homekit - "Couldn't add Home Assistant Bridge"

Tags: #<Tag:0x00007f7390854a70>

Hi everyone.

Trying to set up the Homekit integration.
I’m using an old iPad (gen 4) running iOS 10.3.4, and HA (prev Hassio) running on Raspberry Pi 3+, updated to latest versions of HA and OS.

I add the integration, choose entity domains, and get the notification with the QR code and passcode.
Go to the iPad, add accessory, click on HASS Bridge ####. The QR code fails to scan, so I have to manually enter the passcode.

Enter the code, the notification briefly disappears in HA while the iPad thinks, before the iPad reports that it:
Couldn’t add HASS Bridge ####
Home couldn’t connect to this accessory

Any help greatly appreciated. :slight_smile:

Thanks

Same for me. Any solutions yet?

Ongoing unfortunately…

1 Like

UPDATE:
I tested the integration with an iPhone XS running iOS 14. Works fine, everything as expected.
Which lead me to think that it was the iPad at fault.

I managed to install Homebridge in Portainer and tried adding that to Homekit on the iPad. Worked perfectly.
Managed to connect Home Assistant to Homebridge and devices appeared in the Home App. All works fine, apart from device state isn’t synced properly in the Home App, but that’s another conversation!

So it appears the Homekit integration doesn’t work with older versions of iOS for some reason?
Can anyone shed any light on this?

Sorted it.
My issue was to do with the number of entities being added to the bridge. There’s a limit of 150 which seems to crash with older versions of iOS/Homekit.

I had to choose the domains I wanted to share, and then choose the entities I did NOT want to share (which seems a little counter intuitive).

All working now. :slight_smile:

1 Like