HomeKit Devices Default


#1

I have a question for anybody that might know.

Has anybody else sometimes have their devices default back into the area where the HomeKit Hub is placed after restarts of HA? It’s not always but very annoying since I use a lot of these devices in automations via my iPhone Home App. Does anybody have a solution for this?


#2

I think it happens if the devices aren’t available on start. There are guidelines to manage HomeKit to keep that from happen


#3

I do have this in my automation.yaml

- alias: 'Start HomeKit'
  trigger:
  - event: start
    platform: homeassistant
  condition: []
  action:
  - delay: 00:05  # Waits 5 minutes
  - service: homekit.start

Is there something else to add?


#4

Looking for a solution myself.
Becomes especially annoying when Door lock notifications turn on automatically.


#5

No, unfortunately ALL entities need to be loaded before Homekit starts. If you receive an error at startup for whatever reason (and you didn’t notice it) there is a great possibility that it did not load all the entities. If so, homekit wil treat them as “new” devices thus resetting everything. (I had massive problems with this, as my xiaomi gateway had problems loading sometimes, I need to cut the power to that device before it will be recognised again). Also resetting your mqtt database will do the same thing. My personal advice is: move away from Homekit if you do not really need it. Home Assistant is extremely customizable and you could basically make almost the same interface as Apple’s one.

If you do rely on Homekit then I can only suggest you make absolutely sure everything is loaded before Homekit starts. Changing an entity in any way will also trigger Homekit to treat it as a new device.

Edit: I have used OpenHAB in the past, this has the same problem.


#6

Unfortunately I have to keep HomeKit to keep the wife happy. Lol

I’ll just extend the wait time and hope for the best! Thanks for the feedback all!


#7

Maybe try Tileboard, it is a webinterface for Home Assistant which can look like Homekit.

Or you could make anything like this:

Or you could go the lovelace route, a bit harder to configure but well worth it:


The code for my lovelace setup can be found here, I’ll upload my Tileboard version soon.

If your wife doesn’t use Siri you should be fine. My wife is actually more content with what I made (as it is more intelligent, much more flexible, gives more information, more buttons on one page etc etc). And the thing that annoyed my wife the most was the ever changing icons/rooms in Homekit (the problem you are currently facing). We both use lovelace and tileboard now and we never looked back. I hope it helps.


#8

I’ve had this problem occasionally, what I did was migrate any automations/config that were in HomeKit over to HA. I really only use for Siri integration so it doesn’t matter if my devices are assigned to the correct “room” in HomeKit. The only disadvantage is I have to tell Siri what lights to turn on (normally if you tell your HomePod to “turn on the lights” it will know what room your HomePod is assigned to and only turn on the lights in that room).

One idea I think I read in the HomeKit docs would be to make a switch/input boolean for each of your smart devices (lights, switches, etc) and only expose those copies to HomeKit, theoretically they’d always be ready immediately so HomeKit wouldn’t lose their config.


#9

@Corey_Maxim Check out the last example in the Disable Auto Start section. It was just recently added and should be the solution to your issues. It’s even an improvement from what @TravelinMax suggested.